This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 414421 - Can't config display on PS3
Can't config display on PS3
Status: CLOSED DUPLICATE of bug 374581
Product: Fedora
Classification: Fedora
Component: system-config-display (Show other bugs)
8
ppc64 Linux
low Severity high
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-06 12:20 EST by Gary Thomas
Modified: 2008-04-11 15:06 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-11 15:06:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gary Thomas 2007-12-06 12:20:59 EST
Description of problem:

Installing on PS3 (https://bugzilla.redhat.com/show_bug.cgi?id=370761)
Work around this with an updated videocard.py, one still can't configure
the system (I had 480i display initially and now want to move to 1080p)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Run 'system-config-display' on PS3
2.
3.
  
Actual results:

Python failure:
Traceback (most recent call last):
  File "/usr/share/system-config-display/xconf.py", line 381, in <module>
    dialog = xConfigDialog.XConfigDialog(hardware_state, xconfig,
rhpxl.videocard.VideoCardInfo())
  File "/usr/share/system-config-display/xConfigDialog.py", line 533, in __init__
    self.state.recalc_mode()
  File "/usr/lib/python2.5/site-packages/rhpxl/xhwstate.py", line 387, in
recalc_mode
    self.colordepth = availableDepth[-1]
IndexError: list index out of range


Expected results:


Additional info:
Comment 1 Jason 2007-12-09 19:13:24 EST
Have you tried using ps3videomode to change the resolution? 
ps3videomode -v 5 will change it to 1080p

In /etc/yaboot.conf you can append 

video=1080p

to make the change permanent. system-config-display will not work for this...

If you wanted system-config-display to work you'd probably need to submit a
feature request to support it. 
Comment 2 Gary Thomas 2007-12-10 03:08:04 EST
Even if this is the case, running 'system-config-display' (which is what
happens with the menu item Sytem->Administration->Display) should not
crash (if you use the menu, it just silently goes away...)
Comment 3 Adam Jackson 2008-04-11 15:06:08 EDT

*** This bug has been marked as a duplicate of 374581 ***

Note You need to log in before you can comment on or make changes to this bug.