Bug 414461 - Can't push patch cluster to 5.0 satellite
Can't push patch cluster to 5.0 satellite
Status: CLOSED CURRENTRELEASE
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris (Show other bugs)
501
All Linux
low Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
: Regression
: 433630 (view as bug list)
Depends On:
Blocks: 248637
  Show dependency treegraph
 
Reported: 2007-12-06 13:06 EST by Justin Sherrill
Modified: 2008-04-02 16:36 EDT (History)
1 user (show)

See Also:
Fixed In Version: sat510
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-02 16:36:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Justin Sherrill 2007-12-06 13:06:14 EST
Whenever i try to push a patch cluster to a 5.0 satellite with rhnpush-5.0.0-7,
it sits for a very long time and then gets an ISE from the server.  The
traceback i get from the server is:

RHN 27601 2007/12/05 14:03:28 -04:00: ('Unhandled exception',)
Exception reported from dually.rdu.redhat.com
Time: Wed Dec  5 14:05:26 2007
Exception type server.rhnSQL.sql_base.SQLError
Exception while handling function upload_server._wrapper
Request object information:
URI: /PACKAGE-PUSH
Remote Host: 172.16.57.177
Server Name: dually.rdu.redhat.com:80
Headers passed in:
        Accept-Encoding: identity
        Content-Length: 333591732
        Content-Type: application/x-rpm
        Host: dually.rdu.redhat.com
        User-Agent: rhnpush
        X-RHN-Upload-Auth-Session: 196861x675a628dbac2d64755186b746a2ec082
        X-RHN-Upload-File-MD5sum: 5345e511c5bd118d868ea1cbe4425422
        X-RHN-Upload-Force: 0
        X-RHN-Upload-Package-Arch: sparc-solaris-patch-cluster
        X-RHN-Upload-Package-Name: patch-cluster-solaris-10_Recommended
        X-RHN-Upload-Package-Release: 1
        X-RHN-Upload-Package-Version: 20071019
        X-RHN-Upload-Packaging: mpm

Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheUploadServer.py", line 97, in _wrapper
    ret = function(req)
  File "/usr/share/rhn/upload_server/handlers/package_push/package_push.py",
line 133, in handler
    relative_path=self.rel_package_path, org_id=self.org_id)
  File "/usr/share/rhn/server/rhnPackageUpload.py", line 210, in push_package
    importer.run()
  File "/usr/share/rhn/server/importlib/importLib.py", line 593, in run
    self.submit()
  File "/usr/share/rhn/server/importlib/packageImport.py", line 285, in submit
    transactional=self.transactional)
  File "/usr/share/rhn/server/importlib/backend.py", line 677, in processPackages
    transactional=transactional)
  File "/usr/share/rhn/server/importlib/backend.py", line 1403, in
__processObjectCollection__
    return self.__doDML(dml)
  File "/usr/share/rhn/server/importlib/backend.py", line 1509, in __doDML
    self.__doInsert(dml.insert, dml.tables)
  File "/usr/share/rhn/server/importlib/backend.py", line 1515, in __doInsert
    self.__doInsertTable(tname, dict)
  File "/usr/share/rhn/server/importlib/backend.py", line 1527, in __doInsertTable
    insertObj.query(hash)
  File "/usr/share/rhn/server/importlib/backendLib.py", line 419, in query
    executeStatement(statement, values, self.count)
  File "/usr/share/rhn/server/importlib/backendLib.py", line 449, in
executeStatement
    count = count + apply(statement.executemany, (), tempdict)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 103, in executemany
    return apply(self._execute_wrapper, (self._executemany, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 159, in _execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (1400, 'ORA-01400: cannot insert NULL into
("RHNSAT"."RHNSOLARISPATCHSETMEMBERS"."PATCH_ID")\n', 'insert into
rhnSolarisPatchSetMembers (patch_set_id, patch_id, patch_order) values
(:patch_set_id, :patch_id, :patch_order)')

RHN 11903 2007/12/05 14:05:27 -04:00: ('Unhandled exception',)



Note, i only get the error when pushing patch clusters and not patches.
Comment 1 Pradeep Kilambi 2008-01-22 19:32:53 EST
ok I think I found the issue with clusters. Apparently to upload a patch cluster
you need to fist upload all the patches the cluster contains. That si all mpm's
and then upload the cluster. So I had to first run:

[pkilambi@prad ~]$ rhnpush --server=http://dually.rdu.redhat.com/APP
--user=admin --password=redhat -c solaris-sparc patch-solaris-1*  -vvv

and then upload the cluster as follows:

[pkilambi@prad ~]$ rhnpush --server=http://dually.rdu.redhat.com/APP
--user=admin --password=redhat -c solaris-sparc
patch-cluster-solaris-10_Recommended-20071019-1.sparc-solaris-patch-cluster.mpm
 -vvv
Connecting to http://dually.rdu.redhat.com/APP
url is http://dually.rdu.redhat.com/PACKAGE-PUSH
Result codes: 200 OK
Computing md5sum and package Info .This may take sometime ...
Package
patch-cluster-solaris-10_Recommended-20071019-1.sparc-solaris-patch-cluster.mpm
Not Found on RHN Server -- Uploading
Uploading package
patch-cluster-solaris-10_Recommended-20071019-1.sparc-solaris-patch-cluster.mpm
Using POST request
[pkilambi@prad ~]$

the cluster should now appear in the channel:

https://dually.rdu.redhat.com/network/software/channels/patchsets.pxt?cid=148

So as the patches dint exist already on server it was not able to get the
patch_id for each of these in the cluster and hence it was not able to link then
into rhnSolarisPatchSetMembers which needed patch_id  and this value ended up
being None for the ones that dint already exist in the channel.
Comment 2 Pradeep Kilambi 2008-01-29 10:54:32 EST
Sending        importlib/packageImport.py
Transmitting file data .
Committed revision 136258.
Comment 3 Brandon Perkins 2008-02-05 00:29:16 EST
Verified.
Comment 4 Pradeep Kilambi 2008-02-20 10:00:18 EST
*** Bug 433630 has been marked as a duplicate of this bug. ***
Comment 5 Mike McCune 2008-03-26 01:07:46 EDT
pushed patch clusters in stage and they showed up in UI ok.
Comment 6 Brandon Perkins 2008-04-02 16:36:06 EDT
Solaris Management Build 5.1 Sat GA so Closed for Current Release.

Note You need to log in before you can comment on or make changes to this bug.