Bug 433630 - prb of rhnpush of a solaris patch cluster
Summary: prb of rhnpush of a solaris patch cluster
Status: CLOSED DUPLICATE of bug 414461
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Solaris
Version: 501
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Clifford Perry
QA Contact: Brandon Perkins
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-20 14:45 UTC by Giuseppe Paterno
Modified: 2008-02-20 15:00 UTC (History)
1 user (show)

(edit)
Clone Of:
(edit)
Last Closed: 2008-02-20 15:00:16 UTC


Attachments (Terms of Use)

Description Giuseppe Paterno 2008-02-20 14:45:38 UTC
I'm trying uploading a solaris patch cluster using rhnpush. The patch cluster
has already been converted using solaris2mpm. This is the command:

# rhnpush -v --server mysat.domain.com --username admin --password password -c
sol8_sparc 
patch-cluster-solaris-8_Recommended-20080211-1.sparc-solaris-patch-cluster.mpm

From a client perspective, the error is "500, internal server error".
In the apache logs (errorlog) I got the following (note the ora error):

----------------------------------------------------------------------------------------------------------------
RHN 30656 2008/02/20 15:08:27 +02:00: ('Unhandled exception',)

Exception reported from XXXXXXXXX
Time: Wed Feb 20 15:13:56 2008

Exception type server.rhnSQL.sql_base.SQLError
Exception while handling function upload_server._wrapper

Request object information:
URI: /PACKAGE-PUSH
Remote Host: 127.0.0.1
Server Name: rhsat.telecomitalia.it:80

Headers passed in:
        Accept-Encoding: identity
        Content-Length: 175190570
        Content-Type: application/x-rpm
        Host: localhost
        User-Agent: rhnpush
        X-RHN-Upload-Auth-Session: 39x37d2cabaf0f68beb0614e97cb5e17bab
        X-RHN-Upload-File-MD5sum: ac3e049015aaec800d239812cf6bd08b
        X-RHN-Upload-Force: 0
        X-RHN-Upload-Package-Arch: sparc-solaris-patch-cluster
        X-RHN-Upload-Package-Name: patch-cluster-solaris-8_Recommended
        X-RHN-Upload-Package-Release: 1
        X-RHN-Upload-Package-Version: 20080211
        X-RHN-Upload-Packaging: mpm
 
Exception Handler Information
Traceback (most recent call last):
  File "/usr/share/rhn/server/apacheUploadServer.py", line 97, in _wrapper
    ret = function(req)
  File "/usr/share/rhn/upload_server/handlers/package_push/package_push.py",
line 133, in handler
    relative_path=self.rel_package_path, org_id=self.org_id)
  File "/usr/share/rhn/server/rhnPackageUpload.py", line 210, in push_package
    importer.run()
  File "/usr/share/rhn/server/importlib/importLib.py", line 593, in run
    self.submit()
  File "/usr/share/rhn/server/importlib/packageImport.py", line 285, in submit
    transactional=self.transactional)
  File "/usr/share/rhn/server/importlib/backend.py", line 677, in processPackages
    transactional=transactional)
  File "/usr/share/rhn/server/importlib/backend.py", line 1403, in
__processObjectCollection__
    return self.__doDML(dml)
  File "/usr/share/rhn/server/importlib/backend.py", line 1509, in __doDML
    self.__doInsert(dml.insert, dml.tables)
  File "/usr/share/rhn/server/importlib/backend.py", line 1515, in __doInsert
    self.__doInsertTable(tname, dict)
  File "/usr/share/rhn/server/importlib/backend.py", line 1527, in __doInsertTable
    insertObj.query(hash)
  File "/usr/share/rhn/server/importlib/backendLib.py", line 419, in query
    executeStatement(statement, values, self.count)
  File "/usr/share/rhn/server/importlib/backendLib.py", line 449, in
executeStatement
    count = count + apply(statement.executemany, (), tempdict)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 103, in executemany
    return apply(self._execute_wrapper, (self._executemany, ) + p, kw)
  File "/usr/share/rhn/server/rhnSQL/int_oracle.py", line 159, in _execute_wrapper
    raise apply(sql_base.SQLError, ret)
SQLError: (1400, 'ORA-01400: cannot insert NULL into
("RHNSAT"."RHNSOLARISPATCHSETMEMBERS"."PATCH_ID")\n', 'insert into
rhnSolarisPatchSetMembers (patch_set_id, patch_id, patch_order) values
(:patch_set_id, :patch_id, :patch_order)')

RHN 30659 2008/02/20 15:14:08 +02:00: ('Unhandled exception',)


----------------------------------------------------------------------------------------------------------------

Thanks for any hint

Comment 1 Pradeep Kilambi 2008-02-20 15:00:16 UTC

*** This bug has been marked as a duplicate of 414461 ***


Note You need to log in before you can comment on or make changes to this bug.