Bug 41452 - unresolved smux_listen_sd in libucdmibs for ucd-snmp-4.2-12 (simple fix[?])
Summary: unresolved smux_listen_sd in libucdmibs for ucd-snmp-4.2-12 (simple fix[?])
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp   
(Show other bugs)
Version: 7.1
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact: Brock Organ
URL: https://sourceforge.net/tracker/index...
Whiteboard:
Keywords:
: 42335 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-20 19:46 UTC by Jack Perdue
Modified: 2015-03-05 01:09 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-06-05 19:45:06 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch - ucd-snmp-4.2-smux.patch (1.10 KB, patch)
2001-05-21 13:43 UTC, Jack Perdue
no flags Details | Diff

Description Jack Perdue 2001-05-20 19:46:36 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.08 [en] (Win95; U ;Nav)

Description of problem:
smux_listen_sd is unresoved in /usr/lib/libucdmibs.so.0.4.2 on   RedHat 7.1 because: 

  a) RH enables the smux module

   * Tue Mar 13 2001 Matt Wilson <msw@redhat.com>
      - configure with --enable-reentrant and added "smux" and "agentx" to

  b) smux_listen_sd is (improperly?) defined in agents/snmpd.c but 
       also referenced in agents/mibagents/smux/smux.c (which gets 
       built into libucdmibs) 

I think the proper fix is to move the definition of int smux_listen_sd 
from snmpd.c to smux.c. 

How reproducible:
Always

Steps to Reproduce:
1. Create t.c as follows (taken from the ntop package's configure):

char register_mib();
int main() {
register_mib()
; return 0; }

2. Compile:

 gcc t.c /usr/lib/libucdagent.so.0 /usr/lib/libsnmp.so.0  /usr/lib/libucdmibs.so.0 -lrpm -lssl -lrpmio -lpopt

	

Actual Results:  [root@blacktop ntop-2.devel]# gcc t.c /usr/lib/libucdagent.so.0 /usr/lib/libsnmp.so.0
/usr/lib/libucdmibs.so.0 -lrpm -lssl -lrpmio -lpopt -v
Reading specs from /usr/lib/gcc-lib/i386-redhat-linux/2.96/specs
gcc version 2.96 20000731 (Red Hat Linux 7.1 2.96-81)
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/cpp0 -lang-c -v -D__GNUC__=2 -D__GNUC_MINOR__=
96 -D__GNUC_PATCHLEVEL__=0 -D__ELF__ -Dunix -Dlinux -D__ELF__ -D__unix__ -D__linux__ -D
__unix -D__linux -Asystem(posix) -Acpu(i386) -Amachine(i386) -Di386 -D__i386 -D__i386__
 -D__tune_i386__ t.c /tmp/ccQjziiC.i
GNU CPP version 2.96 20000731 (Red Hat Linux 7.1 2.96-81) (cpplib) (i386 Linux/ELF)
ignoring nonexistent directory "/usr/local/include"
ignoring nonexistent directory "/usr/i386-redhat-linux/include"
#include "..." search starts here:
#include <...> search starts here:
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/include
 /usr/include
End of search list.
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/cc1 /tmp/ccQjziiC.i -quiet -dumpbase t.c -vers
ion -o /tmp/cck7TCV5.s
GNU C version 2.96 20000731 (Red Hat Linux 7.1 2.96-81) (i386-redhat-linux) compiled by
 GNU C version 2.96 20000731 (Red Hat Linux 7.1 2.96-81).
 as -V -Qy -o /tmp/ccYLBqkC.o /tmp/cck7TCV5.s
GNU assembler version 2.10.91 (i386-redhat-linux) using BFD version 2.10.91.0.2
 /usr/lib/gcc-lib/i386-redhat-linux/2.96/collect2 -m elf_i386 -dynamic-linker /lib/ld-l
inux.so.2 /usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crt1.o /usr/lib/gcc-lib/i386
-redhat-linux/2.96/../../../crti.o /usr/lib/gcc-lib/i386-redhat-linux/2.96/crtbegin.o -
L/usr/lib/gcc-lib/i386-redhat-linux/2.96 -L/usr/lib/gcc-lib/i386-redhat-linux/2.96/../.
./.. /tmp/ccYLBqkC.o /usr/lib/libucdagent.so.0 /usr/lib/libsnmp.so.0 /usr/lib/libucdmib
s.so.0 -lrpm -lssl -lrpmio -lpopt -lgcc -lc -lgcc /usr/lib/gcc-lib/i386-redhat-linux/2.
96/crtend.o /usr/lib/gcc-lib/i386-redhat-linux/2.96/../../../crtn.o
/usr/lib/libucdmibs.so.0: undefined reference to `smux_listen_sd'
collect2: ld returned 1 exit status
[root@blacktop ntop-2.devel]#

Expected Results:  Ideally, smux_listen_sd would be defined if needed.

Additional info:

bug #425720 on the net-snmp sourceforge site

Comment 1 Jack Perdue 2001-05-21 13:43:44 UTC
Created attachment 19150 [details]
proposed patch - ucd-snmp-4.2-smux.patch

Comment 2 Phil Knirsch 2001-05-31 08:33:59 UTC
OK, that patches looks very sane, i'll put it in the package next time i build
it. Should appear in rawhide over the next few weeks.

Read ya, Phil

Comment 3 Phil Knirsch 2001-06-05 19:45:02 UTC
*** Bug 42335 has been marked as a duplicate of this bug. ***

Comment 4 Phil Knirsch 2001-06-26 15:16:47 UTC
Fixed in rawhide.

Read ya, Phil


Note You need to log in before you can comment on or make changes to this bug.