Bug 42335 - unresolved symbols from rpmlib when building w/ ucd-snmp 4.2-12
unresolved symbols from rpmlib when building w/ ucd-snmp 4.2-12
Status: CLOSED DUPLICATE of bug 41452
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
7.1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
Brock Organ
http://net-snmp.sourceforge.net/tutor...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-25 17:02 EDT by Scott Leerssen
Modified: 2015-03-04 20:09 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-25 17:02:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Scott Leerssen 2001-05-25 17:02:45 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
It appears that the ucd-snmp package was not built on a 7.1 system.  When I
build the sources from the net-snmp site (referenced URL), I get a whole
bunch of unresolved symbols when the ustMain program builds.  If I get the
sources for ucd-snmp, the configure script compensates for the missing
symbols, which leads me to believe that an older system was used to build
the rpm.  Note also that this problem does not occur on a 7.0 system, which
again, leads me to believe that the rpm was built on a non-vanilla 7.1
sytem.

One more note: the unresolved symbols occur only with the shared library
libucdmibs.so.  If I link against the .a file, all is well.

How reproducible:
Always

Steps to Reproduce:
1.download the sources from the aforementioned URL
2.build
3.boom
	

Actual Results:  lots of undefined references to rpmlib functions

Expected Results:  build with no failures

Additional info:
Comment 1 Phil Knirsch 2001-06-05 15:45:06 EDT

*** This bug has been marked as a duplicate of 41452 ***

Note You need to log in before you can comment on or make changes to this bug.