Bug 415491 - Jwhois is unusable with IPv4 only connections on RHEL 5.x.x
Summary: Jwhois is unusable with IPv4 only connections on RHEL 5.x.x
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: jwhois
Version: 5.5
Hardware: All
OS: Linux
Target Milestone: rc
: ---
Assignee: Vitezslav Crhonek
QA Contact:
: 625881 (view as bug list)
Depends On:
TreeView+ depends on / blocked
Reported: 2007-12-07 10:36 UTC by Robert Scheck
Modified: 2018-11-14 19:45 UTC (History)
4 users (show)

Clone Of:
Last Closed: 2010-10-06 16:20:24 UTC

Attachments (Terms of Use)

External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2010:0745 normal SHIPPED_LIVE jwhois bug fix and enhancement update 2010-10-06 16:20:04 UTC

Description Robert Scheck 2007-12-07 10:36:06 UTC
Description of problem:
Jwhois is unusable with IPv4 only connections on RHEL 5.0/5.0.x/5.1/5.1.x when
having to query e.g. whois.ripe.net.

[root@tux ~]# whois
[Querying whois.ripe.net]
[Unable to connect to remote host]
[root@tux ~]#

Version-Release number of selected component (if applicable):

How reproducible:
Everytime, see above.

Actual results:
There's a working patch for Fedora available which should be backported to RHEL.
Further information as well as a backtrace for this are in bug #415481 and bug
#394251. The problem is the exactly same in RHEL and Fedora, when I compared the
strace results.

Expected results:
Working jwhois for whois.ripe.net when having IPv6 only connection. The problem
comes up, because whois.ripe.net has IPv4 and IPv6 addresses and the IPv6 comes
before IPv4 normally.

Comment 1 Robert Scheck 2008-11-01 18:57:48 UTC

Comment 2 Robert Scheck 2009-01-20 22:18:41 UTC
This issue has NOT been solved for RHEL 5.3 - jwhois is still unusable with
IPv4 only connections on RHEL 5.x. Will we get this solved?

Comment 4 Robert Scheck 2010-07-18 11:11:59 UTC
I've cross-filed this issue as Service Request 2041338.

Comment 6 Vitezslav Crhonek 2010-08-25 14:50:05 UTC
*** Bug 625881 has been marked as a duplicate of this bug. ***

Comment 7 Vitezslav Crhonek 2010-08-30 12:15:04 UTC

We discovered another issue during testing, it has same symptoms as in bug #624608. We have a fix, which seems to work fine. Because it modifies original patch (from bug #415481 and bug #394251), I'd like to ask you to test whether it still fixes the problem reported here.

Scratch build can be obtained here:

Comment 8 Vitezslav Crhonek 2010-09-06 13:17:32 UTC

Comment 9 Vitezslav Crhonek 2010-09-22 13:09:45 UTC

Comment 12 errata-xmlrpc 2010-10-06 16:20:24 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.