Bug 415491 - Jwhois is unusable with IPv4 only connections on RHEL 5.x.x
Jwhois is unusable with IPv4 only connections on RHEL 5.x.x
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: jwhois (Show other bugs)
5.5
All Linux
low Severity high
: rc
: ---
Assigned To: Vitezslav Crhonek
:
: 625881 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-07 05:36 EST by Robert Scheck
Modified: 2013-04-12 15:28 EDT (History)
4 users (show)

See Also:
Fixed In Version: jwhois-3.2.3-9.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2010-10-06 12:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Scheck 2007-12-07 05:36:06 EST
Description of problem:
Jwhois is unusable with IPv4 only connections on RHEL 5.0/5.0.x/5.1/5.1.x when
having to query e.g. whois.ripe.net.

[root@tux ~]# whois 81.91.170.12
[Querying whois.ripe.net]
[Unable to connect to remote host]
[root@tux ~]#

Version-Release number of selected component (if applicable):
jwhois-3.2.3-8.el5

How reproducible:
Everytime, see above.

Actual results:
There's a working patch for Fedora available which should be backported to RHEL.
Further information as well as a backtrace for this are in bug #415481 and bug
#394251. The problem is the exactly same in RHEL and Fedora, when I compared the
strace results.

Expected results:
Working jwhois for whois.ripe.net when having IPv6 only connection. The problem
comes up, because whois.ripe.net has IPv4 and IPv6 addresses and the IPv6 comes
before IPv4 normally.
Comment 1 Robert Scheck 2008-11-01 14:57:48 EDT
Ping?
Comment 2 Robert Scheck 2009-01-20 17:18:41 EST
This issue has NOT been solved for RHEL 5.3 - jwhois is still unusable with
IPv4 only connections on RHEL 5.x. Will we get this solved?
Comment 4 Robert Scheck 2010-07-18 07:11:59 EDT
I've cross-filed this issue as Service Request 2041338.
Comment 6 Vitezslav Crhonek 2010-08-25 10:50:05 EDT
*** Bug 625881 has been marked as a duplicate of this bug. ***
Comment 7 Vitezslav Crhonek 2010-08-30 08:15:04 EDT
Robert,

We discovered another issue during testing, it has same symptoms as in bug #624608. We have a fix, which seems to work fine. Because it modifies original patch (from bug #415481 and bug #394251), I'd like to ask you to test whether it still fixes the problem reported here.

Scratch build can be obtained here:
http://people.redhat.com/vcrhonek/
Comment 8 Vitezslav Crhonek 2010-09-06 09:17:32 EDT
Ping?
Comment 9 Vitezslav Crhonek 2010-09-22 09:09:45 EDT
Ping?
Comment 12 errata-xmlrpc 2010-10-06 12:20:24 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on therefore solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2010-0745.html

Note You need to log in before you can comment on or make changes to this bug.