Bug 41552 - SGML catalogs are not installed world-readable
Summary: SGML catalogs are not installed world-readable
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: sgml-common   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 54039 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-21 10:29 UTC by Nicolas Mailhot
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-21 10:34:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Nicolas Mailhot 2001-05-21 10:29:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.4-ac11-lys1 i686; en-US;
rv:0.9+) Gecko/20010520

Description of problem:
For as long as I can remember RH installs SGML catalogs in mode 600.
That means only root can do any SGML editing !
These are not secret files ; these are ressource files ; everybody should
be able to read their contents

How reproducible:
Always

Steps to Reproduce:
1. Install a new sgml catalog rpm
2. Try any sgml editing as a normal user (in psgml mode)
3. Try do validate your result

Read the + nsgmls:/etc/sgml/catalog:1:8:E: cannot open
"/etc/sgml/sgml-docbook-3.0.cat" ; message

Expected Results:  The validation should have proceeded normally without
any read error

Additional info:

It's a very old bug, I just got tired of changing the permissions after
every /usr/bin/install-catalog run

Comment 1 Tim Waugh 2001-05-21 10:34:37 UTC
I can't reproduce this here, but I think I see how it's happening.  
install-catalog isn't careful enough to set the permissions on files it 
creates, and so they just have default (umask-determined) permissions.  Root's 
default umask is 022, and so this works for most people.

install-catalog needs to chmod 0644 all the files that it creates.


Comment 2 Tim Waugh 2001-05-21 11:01:07 UTC
Should be fixed in sgml-common-0.5-6.


Comment 3 Tim Waugh 2001-09-26 11:47:31 UTC
*** Bug 54039 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.