Bug 416731 - Pirut Crashes During Opening
Pirut Crashes During Opening
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
8
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
: 426923 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-08 14:10 EST by Dave
Modified: 2008-01-15 18:12 EST (History)
4 users (show)

See Also:
Fixed In Version: 1.1.10-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-15 17:53:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Pirut bug report (6.60 KB, text/plain)
2007-12-08 14:10 EST, Dave
no flags Details

  None (edit)
Description Dave 2007-12-08 14:10:56 EST
Description of problem: Pirut crashes during opening


Version-Release number of selected component (if applicable):


How reproducible: It happens every time you open it, after the last update.


Steps to Reproduce:
1.Open the program
2.It crashes
3.
  
Actual results:


Expected results: For pirut to work as it should.


Additional info:
Comment 1 Dave 2007-12-08 14:10:56 EST
Created attachment 282081 [details]
Pirut bug report
Comment 2 Luke Macken 2007-12-10 14:52:45 EST
Thanks for the bug report, Dave.  Could you please try downloading this file and
copying it to /usr/lib/yum-plugins, and see if that fixes it.

http://lmacken.fedorapeople.org/tmp/fastestmirror.py
Comment 3 Mark Harig 2007-12-25 21:04:06 EST
My computer also had the problem with pirut that is described above, with the
same line numbers in the python code.  I followed the instructions in Comment #2
after renaming my 'fastestmirror.py' and 'fastestmirror.pyc' files.

I was then able to start 'pirut' via the Applications|Add/Remove Software menu
item without any errors.

My setup is different from the above in that I have a different set of
repositories and I am running Fedora 8 on the x86_64 platform.

$ rpm -q pirut
pirut-1.3.28-1.fc8.noarch

$ rpm -q yum-fastestmirror
yum-fastestmirror-1.1.9-1.fc8.noarch

$ rpm -q yum
yum-3.2.8-2.fc8.noarch

$ rpm -q rpm
rpm-4.4.2.2-7.fc8.x86_64
Comment 4 Max Kanat-Alexander 2007-12-27 23:34:14 EST
That seems to answer the question.
Comment 5 Jeremy Katz 2007-12-28 08:49:10 EST
*** Bug 426923 has been marked as a duplicate of this bug. ***
Comment 6 Mark Harig 2008-01-03 18:41:11 EST
This problem has returned with the recent update to the 'yum-fastestmirror' RPM
package.  At the start of pirut, a python stack traceback is generated with
nearly the same line numbers as the originally attached log.  I downloaded the
suggested fix at http://lmacken.fedorapeople.org/tmp/fastestmirror.py again, and
again copied it over the file in /usr/lib/yum-plugins.  This again resolved the
problem, i.e., pirut starts without error.

Here are some relevant details:

$ rpm -qf /usr/lib/yum-plugins/fastestmirror.py
yum-fastestmirror-1.1.9-2.fc8.noarch

$ diff /usr/lib/yum-plugins/fastestmirror.py /tmp/fastestmirror.py
97c97,98
<         conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
---
>         if len(repo.urls):
>             conduit.info(2, " * %s: %s" % (str(repo), host(repo.urls[0])))
Comment 7 Tim Lauridsen 2008-01-04 07:06:28 EST
I have just build a yum-utils-1.1.10 there contains an updated fastestmirror.py
fixing this issue, it should be hitting updates-testing at next push.
Comment 8 Fedora Update System 2008-01-06 20:16:31 EST
yum-utils-1.1.10-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'
Comment 9 Fedora Update System 2008-01-06 20:21:10 EST
yum-utils-1.1.10-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-utils'
Comment 10 Fedora Update System 2008-01-15 17:53:37 EST
yum-utils-1.1.10-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 11 Fedora Update System 2008-01-15 18:12:40 EST
yum-utils-1.1.10-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.