Bug 417181 - update to 2.12.2-2.fc8 breaks evolution
Summary: update to 2.12.2-2.fc8 breaks evolution
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution   
(Show other bugs)
Version: 8
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-12-09 13:04 UTC by Armijn Hemel
Modified: 2007-12-11 07:46 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-10 23:39:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Armijn Hemel 2007-12-09 13:04:40 UTC
Description of problem:

After an update to 2.12-2 whenever I start Evolution and am asked to type in my
IMAP password in a dialogue box (I'm not using the keyring) the dialogue box
becomes unresponsive and just seems to die.

Version-Release number of selected component (if applicable):

2.12.2-2

How reproducible:

Always

Steps to Reproduce:
1. update to 2.12.2-2
2. access IMAP account, without storing the password in the keyring
3.
  
Actual results:

Dialogue box seems to die, Evolution becomes unresponsive.

Expected results:

Evolution should work as usual.

Additional info:

A downgrade to 2.12.1-3 fixes the problem for me.

Comment 1 Milan Crha 2007-12-10 11:32:12 UTC
Strange, works for me. For me, it asks to unlock keyring, I hit "Deny", then it
asks me for password for each account I have, after every password entered it
asks me for keyring password again and I again hit "Deny". It works for me for
2xPOP and 1xIMAP account. Are you sure the second keyring dialog isn't "hidden
under Evolution window" and Evolution waits for the response of that dialog? (I
guess, just in case.) And second thing, can you try to install debug info
packages for evolution, evolution-data-server and gtkhtml3 and attach gdb to the
stuck Evolution process and attach here result of "thread apply all bt" command
from gdb? There will be shown where it get stuck. Thanks in advance.

Comment 2 Armijn Hemel 2007-12-10 23:39:07 UTC
Hm. It works for me now too. I guess it must have been some leftover junk
(sockets, whatever), that would only go away with a reboot, even though I did
stop evolution, evolution-data-server and other processes before the upgrade. I
will keep an eye on it, since I could repeat it when I installed it.

I guess it can be closed for now. I will reopen when it comes back. Thanks for
testing.

Comment 3 Milan Crha 2007-12-11 07:46:21 UTC
Probably same as bug #418971, because same part of Evolution (keyring and
passwords). When you get it stuck again, please compare backtraces, it may be
same, I guess.


Note You need to log in before you can comment on or make changes to this bug.