Bug 417451 - sound became crackly
sound became crackly
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Lennart Poettering
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-09 15:35 EST by Richard Schwarting
Modified: 2008-10-01 13:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-10-01 13:42:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
scsconfig (46.58 KB, text/plain)
2007-12-09 15:35 EST, Richard Schwarting
no flags Details

  None (edit)
Description Richard Schwarting 2007-12-09 15:35:18 EST
Description of problem:

My girlfriend has a Macbook.  After updating her packages to-day (the first time
in a few weeks), the sound became crackly.  I wanted to quickly test
system-config-soundcard's default sound (once when my sound went crackly, I
found that s-c-s's demo sound was still clear!).  However, when I try, no sound
is produced!  I found this weird given that rhythmbox et al still can play sound.  

Version-Release number of selected component (if applicable):
system-config-soundcard-2.0.6-11.fc8

How reproducible:
Always, on her Macbook (not a problem on my Acer 5100)

Steps to Reproduce:
1. open s-c-s
2. click play button for demo
  
Actual results:
I hear nothing.

Expected results:
I should hear the pleasant demo sound.

Additional info:
I thought this might be related to pulse-audio, but to the best of my knowledge,
that is set up the same on both her and my laptop (it even "dies" just the same
after suspend, but that's related to haldaemon).  

scsrun.log reports:
"aplay: main:546: audio open error: Device or resource busy"
which I find odd, since I can open a separate terminal and play any .wav file
with aplay.  The sound is just crackly :(
Comment 1 Richard Schwarting 2007-12-09 15:35:18 EST
Created attachment 282331 [details]
scsconfig
Comment 2 Richard Schwarting 2007-12-09 15:51:23 EST
I'll note that the System-Preferences-Hardware-Sound's tests work (albeit with
the disgusting static I note in bug 417481)
Comment 3 Martin Stransky 2008-02-22 05:53:08 EST
Seems to be a pulse-audio bug.
Comment 4 Lennart Poettering 2008-03-28 16:22:09 EDT
Please don't use s-c-s and remove the modprobe.conf fragments it generated.

Please make sure with pavucontrol that PA sucessfully managed to configure your
sound cards. Then, make sure that the stream you want to play back properly
appears in pavucontrol, and move it to the right output device if necessary.
Comment 5 Richard Schwarting 2008-09-30 23:04:21 EDT
My girlfriend upgraded to Fedora 9 in the interim and the issue disappeared.  Sorry about the late response.  I don't suppose I can provide much information now. :)
Comment 6 Lennart Poettering 2008-10-01 13:42:23 EDT
Ok, closing then.

Note You need to log in before you can comment on or make changes to this bug.