Bug 417821 - Assertion failures with F8 OpenGL apps when displaying to Xnewt X server
Assertion failures with F8 OpenGL apps when displaying to Xnewt X server
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: libX11 (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: Søren Sandmann Pedersen
Fedora Extras Quality Assurance
:
: 428953 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 05:31 EST by Pekka Pietikäinen
Modified: 2014-06-18 05:09 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-17 06:31:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Pekka Pietikäinen 2007-12-10 05:31:44 EST
Description of problem:

F8 programs using OpenGL (including ooffice unless explicitly disabled)  do not
work when displaying to the (proprietary) Xnewt server used by Sun's Sun Ray
thin clients.

Version-Release number of selected component (if applicable):

libX11-1.1.3-4.fc8
libxcb-1.0-4.fc8
mesa-libGL-7.0.1-7.fc8

How reproducible:

tk-cn0002 (pp@pts/20):~ >./soffice    
soffice.bin: xcb_io.c:452: _XRead: Assertion               
`dpy->xcb->reply_data != 0' failed.
/usr/lib64/openoffice.org/program/soffice: line 147: 31476 
Aborted                 "$sd_prog/$sd_binary" "$@"

tk-cn0002 (pp@pts/20):~ >glxgears 
glxgears: xcb_io.c:452: _XRead: Assertion `dpy->xcb->reply_data != 0' failed.

A workaround is LD_LIBRARY_PATH:ing to a directory with libX11.so.6 from e.g.
CentOS 5. Also tried libxcb-1.1-1 and  LIBXCB_ALLOW_SLOPPY_LOCK=1, didn't help.
Comment 1 Pekka Pietikäinen 2007-12-10 07:37:31 EST
__glXInitialize in glxext.c 
1143            /* Read each config structure and convert it into our format */
1144            config = psc->configs;
1145            for (j = 0; j < reply.numVisuals; j++) {
1146                assert( config != NULL );
1147                _XRead(dpy, (char *)props, prop_size);
1148

and that loop runs for a few iterations, then fails. For kicks I tried glxinfo
with nvidia libGL, that fails too in similar ways, so it's probably a libX11+xcb
with buggy X server regression thing.


Comment 2 Pekka Pietikäinen 2007-12-17 06:31:18 EST
This is http://bugs.freedesktop.org/show_bug.cgi?id=3210 , which is not fixed in
Xnewt, but has been in Xorg for quite some time. 
Upstream will possibly do a workaround on the libX11 level and if that gets done
the fix will eventually come to Fedora. The real fix needs to be done to Xnewt,
though. I'll try to get a bug reported through our support channels. 
-> closing.
Comment 3 Hana Skoumalová 2008-01-18 05:52:01 EST
*** Bug 428953 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.