Bug 428953 - xcb_io.c:452: _XRead: Assertion `dpy->xcb->reply_data != 0' failed
xcb_io.c:452: _XRead: Assertion `dpy->xcb->reply_data != 0' failed
Status: CLOSED DUPLICATE of bug 417821
Product: Fedora
Classification: Fedora
Component: libxcb (Show other bugs)
8
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-16 07:55 EST by Hana Skoumalová
Modified: 2008-01-18 05:52 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-18 05:52:00 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace on Machine 1 (Sun Java) (40.94 KB, text/plain)
2008-01-16 07:55 EST, Hana Skoumalová
no flags Details
strace on Machine 2 (IcedTea Java, openoffice from the distribution) (38.43 KB, text/plain)
2008-01-16 07:58 EST, Hana Skoumalová
no flags Details

  None (edit)
Description Hana Skoumalová 2008-01-16 07:55:07 EST
Description of problem:

When I try to run OpenOffice I get the following error messages:

soffice.bin: xcb_io.c:452: _XRead: Assertion `dpy->xcb->reply_data != 0' failed.
soffice.bin: xcb_io.c:182: process_responses: Assertion `((int)
(((dpy->last_request_read)) - ((dpy->request))) <= 0)' failed.
/opt/openoffice.org2.3/program/soffice: line 251:  7805 Aborted                
"$sd_prog/$sd_binary" "$@"

This happens on two machines at work, though our home machines work.

Machine 1:
Fedora 8 with SRSS 3.1.1 and Sun Java - we had to apply certain non-standard
patched in order to make SRSS work, but this doesn't seem to be the problem.

Machine 2:
Standard installation of Fedora 8 with IcedTea Java.

On Machine 1, I tried to install OpenOffice package from openoffice.org, but the
result is the same.

How reproducible:
Always on the two machines

Steps to Reproduce:
1. run swriter (or oowriter) from the command-line
2.
3.
  
Actual results:

Machine 1:
soffice.bin: xcb_io.c:452: _XRead: Assertion `dpy->xcb->reply_data != 0' failed.
soffice.bin: xcb_io.c:182: process_responses: Assertion `((int)
(((dpy->last_request_read)) - ((dpy->request))) <= 0)' failed.
/opt/openoffice.org2.3/program/soffice: line 251:  7805 Aborted                
"$sd_prog/$sd_binary" "$@"

Machine 2:
swriter.bin: xcb_io.c:452: _XRead: Assertion `dpy->xcb->reply_data != 0' failed.
/usr/lib64/openoffice.org/program/soffice: line 147: 29552 Aborted             
   "$sd_prog/$sd_binary" "$@"

Expected results:

openoffice launches

Additional info:

I am adding the output of strace.
Comment 1 Hana Skoumalová 2008-01-16 07:55:07 EST
Created attachment 291849 [details]
strace on Machine 1 (Sun Java)
Comment 2 Hana Skoumalová 2008-01-16 07:58:11 EST
Created attachment 291850 [details]
strace on Machine 2 (IcedTea Java, openoffice from the distribution)
Comment 3 Hana Skoumalová 2008-01-18 05:52:00 EST
I was pointed to another bug, which describes this problem. In fact, it is the
fault of SunRay Server. The simple workaround is:

env SAL_NOOPENGL=true ooffice

*** This bug has been marked as a duplicate of 417821 ***

Note You need to log in before you can comment on or make changes to this bug.