Bug 418181 - rawhide-20071209 - loader received SIGABRT!
rawhide-20071209 - loader received SIGABRT!
Status: CLOSED DUPLICATE of bug 378641
Product: Fedora
Classification: Fedora
Component: libdhcp (Show other bugs)
rawhide
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-10 10:34 EST by James Laska
Modified: 2013-09-02 02:23 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-03 23:08:54 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description James Laska 2007-12-10 10:34:27 EST
Description of problem:

loader received SIGABRT!  Backtrace:                                           
[0x401b0e]
[0x4fedb0]
[0x5472b5]
[0x4ff490]
[0x5188c5]
[0x5180c4]
[0x53145e]
[0x531548]
[0x4702b9]
[0x471c9a]
[0x4685d1]
[0x46fcd6]
[0x418471]
[0x41a8ef]
[0x402d9a]
[0x4f08f9]
[0x4001e9]
install exited abnormally [1/1] 


Version-Release number of selected component (if applicable):

rawhide-20071209 which includes anaconda-11.4.0.7-1.x86_64

How reproducible:

100% using a x86_64 pv xen guest (kickstart and manual)

Steps to Reproduce:
1. Boot xen x86_64 pv images
2. Choose English

                   +---------+ Choose a Language +---------+
                   |                                       |
                   | What language would you like to use   |
                   | during the installation process?      |
                   |                                       |
                   |       Catalan                ^        |
                   |       Chinese(Simplified)    :        |
                   |       Chinese(Traditional)   #        |                    
                   |       Croatian               :        |                    
                   |       Czech                  :        |                    
                   |       Danish                 :        |                    
                   |       Dutch                  :        |                    
                   |       English                v        |
                   |                                       |
                   |                +----+                 |
                   |                | OK |                 |
                   |                +----+                 |
                   |                                       |
                   |                                       |
                   +---------------------------------------+

3. Choose URL method
                     +------+ Installation Method +------+                      
                     |                                   |                      
                     | What type of media contains the   |                      
                     | packages to be installed?         |                      
                     |                                   |                      
                     |           Local CD/DVD            |                      
                     |           Hard drive              |                      
                     |           NFS directory           |                      
                     |           URL                     |                      
                     |                                   |                      
                     |     +----+          +------+      |                      
                     |     | OK |          | Back |      |                      
                     |     +----+          +------+      |                      
                     |                                   |                      
                     |                                   |                      
                     +-----------------------------------+                      

4. Select OK

                +-------------+ Configure TCP/IP +-------------+                
                |                                              |                
                | [*] Enable IPv4 support                      |                
                |        (*) Dynamic IP configuration (DHCP)   |                
                |        ( ) Manual configuration              |                
                |                                              |                
                | [*] Enable IPv6 support                      |                
                |        (*) Automatic neighbor discovery      |                
                |        ( ) Dynamic IP configuration (DHCPv6) |                
                |        ( ) Manual configuration              |                
                |                                              |                
                |        +----+               +------+         |                
                |        | OK |               | Back |         |                
                |        +----+               +------+         |                
                |                                              |                
                |                                              |                
                +----------------------------------------------+                
  
Actual results:

loader received SIGABRT!  Backtrace:                                           
[0x401b0e]
[0x4fedb0]
[0x5472b5]
[0x4ff490]
[0x5188c5]
[0x5180c4]
[0x53145e]
[0x531548]
[0x4702b9]
[0x471c9a]
[0x4685d1]
[0x46fcd6]
[0x418471]
[0x41a8ef]
[0x402d9a]
[0x4f08f9]
[0x4001e9]
install exited abnormally [1/1] 

Expected results:

The dialog to enter the URL

Additional info:

NFS installation source fails the same way.

Using
$ eu-addr2line -e /usr/lib/debug/usr/lib/anaconda/loader/loader.debug
/usr/src/debug/anaconda-11.4.0.7/loader2/loader.c:1447
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
??:0
??:0
??:0
??:0
/usr/src/debug/anaconda-11.4.0.7/loader2/net.c:1394
/usr/src/debug/anaconda-11.4.0.7/loader2/net.c:693
/usr/src/debug/anaconda-11.4.0.7/loader2/loader.c:1234
/usr/src/debug/anaconda-11.4.0.7/stubs/unicode-lite.c:28
??:0
Comment 1 James Laska 2007-12-12 09:16:32 EST
Same sig11 with a kickstart install of rawhide on x86_64 using
anaconda-11.4.0.8-1.x86_64

0x401b0e - /usr/src/debug/anaconda-11.4.0.8/loader2/loader.c:1447
0x4fec80 - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x547185 - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x4ff360 - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x518795 - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x517f94 - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x53132e - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x531418 - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x470189 - ??:0
0x471b6a - ??:0
0x4684a1 - ??:0
0x46fba6 - ??:0
0x416b41 - /usr/src/debug/anaconda-11.4.0.8/loader2/net.c:1394
0x418fbf - /usr/src/debug/anaconda-11.4.0.8/loader2/net.c:693
0x402d9a - /usr/src/debug/anaconda-11.4.0.8/loader2/loader.c:1234
0x4f07c9 - /usr/src/debug/anaconda-11.4.0.8/stubs/unicode-lite.c:28
0x4001e9 - ??:0
Comment 2 David Cantrell 2008-01-03 23:08:54 EST

*** This bug has been marked as a duplicate of 378641 ***

Note You need to log in before you can comment on or make changes to this bug.