Bug 419051 - doc license (OPL) is not using free clauses
doc license (OPL) is not using free clauses
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
8
All Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
: Reopened
: 419061 (view as bug list)
Depends On:
Blocks: FE-Legal F9Blocker
  Show dependency treegraph
 
Reported: 2007-12-10 20:00 EST by Karsten Wade
Modified: 2008-04-07 10:13 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-07 10:13:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2007-12-10 20:00:35 EST
In Fedora 7 and 8 (and earlier) versions, system-config-date ships with
documentation that is under the Open Publication License (OPL) 1.0.  This
license usage calls out two optional clauses of the OPL that make the content
not freely modifiable or distributable.  This usage is a remnant from the Red
Hat ownership of the package when all docs were under that style of OPL; this is
no longer the case, and Fedora uses the OPL *only* without the optional clauses.

The file is:

/usr/share/doc/system-config-date-<version>/legalnotice.html

Below are two texts.  (A) shows the license as how it currently appears in the
package.  (B) shows how it should appear.  We may also want to update the
copyright notice, although if the content hasn't changed at all since then,
perhaps not.

BTW, one benefit of this change is that Fedora Docs can then use the content for
the Fedora Administration Guide, and help maintain the upstream version so we
can draw from it downstream into our doc.

You may also want to update the entire legalnotice file (and
copyright), since we no longer are required to call out all those
individual trademarks in that way.  Here is an example of the
legalnotice is constructed now:

http://docs.fedoraproject.org/release-notes/f8/en_US/sn-legalnotice.html

If you want to attach a copy of the XML file to this bug report, I can do the
update and submit a patch.

(A)  
Copyright © 2003 by Red Hat, Inc. This material may be distributed only
subject to the terms and conditions set forth in the Open Publication License,
V1.0 or later (the latest version is presently available at
http://www.opencontent.org/openpub/).

Distribution of substantively modified versions of this document is prohibited
without the explicit permission of the copyright holder.

Distribution of the work or derivative of the work in any standard (paper) book
form for commercial purposes is prohibited unless prior permission is obtained
from the copyright holder.

(B)
Copyright © 2003 by Red Hat, Inc. This material may be distributed only subject
to the terms and conditions set forth in the Open Publication License, V1.0 or
later (the latest version is presently available at
http://www.opencontent.org/openpub/).
Comment 1 Jesse Keating 2008-04-01 16:13:46 EDT
Nils, can we please get this done this week?
Comment 2 Nils Philippsen 2008-04-03 06:24:39 EDT
*** Bug 419061 has been marked as a duplicate of this bug. ***
Comment 3 Nils Philippsen 2008-04-03 06:25:28 EDT
Sorry for the late reply, but I've replaced the online documentation in all my
system-config-* tools a while ago with (partially updated) material from the
RHEL-5 deployment guide, along with this came a change of the license of the
docs to the same as the source code, i.e. GPLv2+.

Is that sufficient? Or do we need/want this dual-licensed GPLv2+/OPL w/o
restrictions? Mike H.?
Comment 4 Tom "spot" Callaway 2008-04-03 14:14:29 EDT
It is sufficient from a Fedora licensing perspective.
Comment 5 Nils Philippsen 2008-04-04 04:20:45 EDT
Mike H., what's the doc group's stance on this?
Comment 6 Michael Hideo 2008-04-06 23:09:54 EDT
Suffient from my perspective. 
Comment 7 Nils Philippsen 2008-04-07 09:58:33 EDT
Great, I'll close this now.
Comment 8 Nils Philippsen 2008-04-07 10:03:58 EDT
Well, since the bug is against F8, I'll put this into MODIFIED until this is
resolved there as well.
Comment 9 Jesse Keating 2008-04-07 10:13:20 EDT
I think this is mostly an upstream issue, and the F8 boat has sailed.  I
wouldn't bother updating on F8 unless you're fixing something else, so I'm going
to close this again.

Note You need to log in before you can comment on or make changes to this bug.