Bug 419061 - doc license (OPL) is not using free clauses
doc license (OPL) is not using free clauses
Status: CLOSED DUPLICATE of bug 419051
Product: Fedora
Classification: Fedora
Component: system-config-services (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
/usr/share/doc/system-config-services...
:
Depends On:
Blocks: FE-Legal F9Blocker
  Show dependency treegraph
 
Reported: 2007-12-10 20:03 EST by Karsten Wade
Modified: 2008-04-03 06:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-04-03 06:24:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Karsten Wade 2007-12-10 20:03:06 EST
In Fedora 7 and 8 (and earlier) versions, system-config-services ships with
documentation that is under the Open Publication License (OPL) 1.0.  This
license usage calls out two optional clauses of the OPL that make the content
not freely modifiable or distributable.  This usage is a remnant from the Red
Hat ownership of the package when all docs were under that style of OPL; this is
no longer the case, and Fedora uses the OPL *only* without the optional clauses.

The file is:

/usr/share/doc/system-config-services-<version>/html/legalnotice.html

Below are two texts.  (A) shows the license as how it currently appears in the
package.  (B) shows how it should appear.  We may also want to update the
copyright notice, although if the content hasn't changed at all since then,
perhaps not.

BTW, one benefit of this change is that Fedora Docs can then use the content for
the Fedora Administration Guide, and help maintain the upstream version so we
can draw from it downstream into our doc.

You may also want to update the entire legalnotice file (and
copyright), since we no longer are required to call out all those
individual trademarks in that way.  Here is an example of the
legalnotice is constructed now:

http://docs.fedoraproject.org/release-notes/f8/en_US/sn-legalnotice.html

If you want to attach a copy of the XML file to this bug report, I can do the
update and submit a patch.

(A)  
Copyright © 2003 by Red Hat, Inc. This material may be distributed only
subject to the terms and conditions set forth in the Open Publication License,
V1.0 or later (the latest version is presently available at
http://www.opencontent.org/openpub/).

Distribution of substantively modified versions of this document is prohibited
without the explicit permission of the copyright holder.

Distribution of the work or derivative of the work in any standard (paper) book
form for commercial purposes is prohibited unless prior permission is obtained
from the copyright holder.

(B)
Copyright © 2003 by Red Hat, Inc. This material may be distributed only subject
to the terms and conditions set forth in the Open Publication License, V1.0 or
later (the latest version is presently available at
http://www.opencontent.org/openpub/).
Comment 1 Jesse Keating 2008-04-01 16:13:36 EDT
Nils, can we get this done this week?  Please?
Comment 2 Nils Philippsen 2008-04-03 06:24:38 EDT
Closing this as dupe of bug #419051 -- I know this is another component and
product version, but what goes for the one also goes for the other.

*** This bug has been marked as a duplicate of 419051 ***

Note You need to log in before you can comment on or make changes to this bug.