Bug 41990 - xscreensaver keeps changing DPMS settings
xscreensaver keeps changing DPMS settings
Status: CLOSED DUPLICATE of bug 37721
Product: Red Hat Linux
Classification: Retired
Component: xscreensaver (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-23 11:02 EDT by Trevin Beattie
Modified: 2014-03-16 22:20 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-23 11:03:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Trevin Beattie 2001-05-23 11:02:57 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i586)

Description of problem:
At first I thought DPMS wasn't working; when I tried putting the monitor in
suspend mode, it would work at first, but about an hour later when I came
back and hit a key the screen popped right up as if it were left on.

I checked X's DPMS settings ('xset q'), and for some strange reason all
three modes were set for 10 seconds.  So I changed them back to what I have
in my Xsetup file--"xset dpms 1800 2400 0"--and switched off again.  About
an hour later I came back to check it, the display came up immediately, and
the DPMS settings had mysteriously been changed once again to "10 10 10".

I found a similar problem in bugzilla under report #37721, so I opened the
xscreensaver demo panel and checked the settings, and sure enough, power
management was disabled, and the three timers were all at 10 seconds.  So I
checked the power management box and set the timers to match my Xsetup
configuration (30 minutes, 40 minutes, 0 [disabled]). I also reset the 
daemon for good measure.  Then I suspended the display, went to bed, and
came back this morning.  Guess what?  The display popped right up, and
'xset q' revealed that all DPMS timeouts had been changed AGAIN to 10
seconds!

Looking at the xscreensaver demo panel, I see that my settings for standby
and suspend are still at 30 and 40 minutes, but the timeout for 'off' had
been changed to 10 seconds, and the "Power Management Enabled" checkbox had
been switched back off.  (On a tangent, I had also turned off the "Display
Splash Screen at Startup" box, but it got switched back on.  I've never
been able to make that setting stay off.)


How reproducible:
Always

Steps to Reproduce:
1. xset dpms 1200 1800 0
2. xscreensaver-demo
3. Under "Screensaver Options", check "Power Management Enabled", set
"Standby After" to "00:30:00", set "Suspend After" to "00:40:00", and set
"Off After" to "00:00:00".  (Also try unchecking "Display Splash Screen At
Startup".)
4. Under "File", click "Restart Daemon".  Then exit.
5. To switch the monitor off immediately, I run the following script:
   #!/bin/sh
   /usr/X11R6/bin/xscreensaver-command -activate
   /usr/X11R6/bin/xscreensaver-command -throttle
   /usr/X11R6/bin/xset dpms force off
   /usr/X11R6/bin/xscreensaver-command -lock
6. Take a break for lunch (or TV or a walk or whatever takes about an
hour...)
7. Hit any key.


Actual Results:  xscreensaver's password dialog shows up immediately.


Expected Results:  If the monitor were really suspended, it would take from
5-10 seconds before the display became visible.


Additional info:

XFree86 Version 4.0.3 / X Window System
(--) ATI(0): ATI 3D Rage Pro graphics controller detected.
(--) ATI(0): Chip type 4742 "GB", version 4, foundry UMC, class 0, revision
0x01.
(--) ATI(0): AGP bus interface detected;  block I/O base is 0xD800.
(--) ATI(0): ATI Mach64 adapter detected.
(--) ATI(0): 8192 kB of SGRAM (1:1) detected.
(**) ATI(0): DPMS enabled

Monitor is a ViewSonic G790
XScreenSaver 3.29
Comment 1 Bill Nottingham 2001-05-23 17:59:19 EDT

*** This bug has been marked as a duplicate of 37721 ***

Note You need to log in before you can comment on or make changes to this bug.