Bug 420041 - [ath5k] No scan results for D-Link DWL-G520 and AR5212 802.11 (b/g)
[ath5k] No scan results for D-Link DWL-G520 and AR5212 802.11 (b/g)
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
: 429658 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 11:42 EST by Joachim Frieben
Modified: 2010-02-03 04:32 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 03:05:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Output of 'lspci -vvnn' for D-Link DWL-G520 Rev. B4 (812 bytes, text/plain)
2007-12-11 11:42 EST, Joachim Frieben
no flags Details

  None (edit)
Description Joachim Frieben 2007-12-11 11:42:53 EST
Description of problem:
The D-Link DWL-G520 Rev. B4 PCI WLAN adapter returns no scan results
when using the ath5k driver whereas it does so when using madwifi.

Version-Release number of selected component (if applicable):
kernel-2.6.23.9-86.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Boot system into single user mode and make sure ath5k is loaded.
2. ifconfig wlan0 up.
3. iwlist wlan0 scan.

Actual results:
iwlist returns 'wlan0     No scan results'

Expected results:
iwlist returns default information for the two access points in
the neighbourhood which are found without any problem when using
the madwifi driver.

Additional info:
The D-Link DWL-G520 Rev. B4 card is based upon an AR5212 802.11 (b/g)
type chipset [Note that 802.11 a is excluded!]. The [attached] ouput
of 'lscpi -vvnn' reports a PCI id of 168c:0013 which is listed at

  http://www.linuxwireless.org/en/users/Drivers/ath5k#supportedchips

and labeled 'OK' as one out of two chips which points to a regression
or incorrect documentation.
Not surprisingly, it's not possible either to establish a working
connection hereafter. The card will never succeed to associate with
the access point using WEP encryption [there is no unencrypted one
around, and I don't have physical access to the access point itself].

Here is the output of 'ath_info' for the DWL-G520 Rev. B4 adapter:

   -==Device Information==-
  MAC Version:  5213A (0x70)
  MAC Revision: 5213A (0x79)
  PHY Revision: 2112a (0x56)
   -==EEPROM Information==-
  EEPROM Version:     5.1
  EEPROM Size:        16K
  Regulatory Domain:  0x30
   -==== Capabilities ====-
  |  802.11a Support: no   |
  |  802.11b Support: yes  |
  |  802.11g Support: yes  |
  |  RFKill  Support: no   |
  |  32KHz   Crystal: no   |
   ========================
  GPIO registers: CR 00000000 DO 00000000 DI 00000010
Comment 1 Joachim Frieben 2007-12-11 11:42:53 EST
Created attachment 284331 [details]
Output of 'lspci -vvnn' for D-Link DWL-G520 Rev. B4
Comment 2 Joachim Frieben 2007-12-11 12:42:38 EST
Ok, I had overlooked the following section on the ath5k driver page:

Notes on supported devices
Please note that 001c is an 802.11bg device. As you can see from
above the current driver design is for 802.11a, 802.11ab, or 802.11abg.
We'll probably need a new device type in the driver for this device to
pass only bg initial register writes and baseband gain settings.
Comment 3 John W. Linville 2007-12-11 13:10:52 EST
As you seem to realize, unfortunately the PCI ID alone is insufficient to 
determine whether or not a given card works with the ath5k driver...
Comment 4 Joachim Frieben 2007-12-18 05:45:54 EST
No improvement for kernel-2.6.24-0.110.rc5.git4.fc9. On the ath5k
development list, a git commit for b/g only cards had been reported,
see:

  https://lists.ath5k.org/pipermail/ath5k-devel/2007-December/000422.html

Is it already included in 2.6.24-0.110.rc5.git4.fc9?
Comment 5 John W. Linville 2007-12-18 11:20:10 EST
Yes, it is.
Comment 6 Jim Haynes 2007-12-21 19:29:38 EST
I've been following bug 254192 which seems related to this one.

My wifi card is a D-Link WNA-2330

I set up my laptop dual boot.  One partition has a Fedora 7 system with all
updates as of 18 Dec and madwifi installed.  On bootup everything seems to
work.

The other partition has never had madwifi installed, and has the kernel
2.6.23.9-45.fc7 installed.  On bootup it creates wlan0, fails at
determining IP information for wlan0, and iwlist wlan0 scan returns
no scan results.

Is this of any interest?
Comment 7 Joachim Frieben 2007-12-31 04:21:25 EST
Based on a register dump of my D-Link DWL-G520 Rev. B4 adapter,
N. Kossifidis has added the missing RF2414A support to the ath5k
driver. After building the module [from a private tarball]
against kernel 2.6.23.12-99.fc8, I'm now able to scan successfully
for APs in my neighbourhood. I do not succeed to associate with
the AP yet though, but things are clearly making progress ..
Comment 8 Paul Simmons 2008-01-22 08:57:49 EST
I have the same symptoms with a TRENDnet TEW-443PI card and kernel
2.6.23.14-115.fc8.

#lspci -v
Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)
        Subsystem: Atheros Communications, Inc. TRENDnet TEW-443PI Wireless PCI
Adapter
        Flags: bus master, medium devsel, latency 168, IRQ 10
        Memory at 40900000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [44] Power Management version 2
        Kernel driver in use: ath5k_pci
        Kernel modules: ath5k

Any clue when the changes will make it upstream?
Comment 9 Joachim Frieben 2008-01-22 11:17:20 EST
A user with your model has confirmed that scanning works for him now, too,
using the private snapshot mentioned in comment #7. However, even for an
unencrypted AP, no data was transmitted. This implies that it maybe more
than a matter of a simple code commit. A major update is pending but a
little patience is needed, see 
https://lists.ath5k.org/pipermail/ath5k-devel/2008-January/000500.html :

 "I have a patch ready but i'll post them all together on my
  next series that 'll addd 2413 support + rf code cleanups/
  refactoring (currently we 're having exams and i don't have
  any time to propertly make a patch series the way i want to)."
Comment 10 John W. Linville 2008-01-24 15:07:11 EST
*** Bug 429658 has been marked as a duplicate of this bug. ***
Comment 11 Joachim Frieben 2008-02-26 16:49:54 EST
The snapshot provided by N. Kossifidis at:

  ftp://www.kernel.org/pub/linux/kernel/people/mickflemm

not only allows to scan successfully for access points but even provides
full connectivity with my D-Link DWL-G520 Rev. B4 !!!
Comment 12 Joachim Frieben 2008-03-11 03:05:44 EDT
Fixed in kernel-2.6.25-0.105.rc5.fc9 which now provides full connectivity as
reported in comment #11 for the latest ath5k patch set.

Note You need to log in before you can comment on or make changes to this bug.