Bug 429658 - cmd: iwlist wlan0 scan - fails to detect APs using "ath5k" driver
cmd: iwlist wlan0 scan - fails to detect APs using "ath5k" driver
Status: CLOSED DUPLICATE of bug 420041
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2008-01-22 03:41 EST by johnnymack
Modified: 2008-01-24 15:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-24 15:07:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
supporting data from lspci, dmesg, lsmod, (4.44 KB, text/plain)
2008-01-22 03:41 EST, johnnymack
no flags Details

  None (edit)
Description johnnymack 2008-01-22 03:41:34 EST
Description of problem:

command: iwlist ath0 scan ..fails to return list of APs.

Version-Release number of selected component (if applicable):

wireless-tools-29-0.2.pre22.fc8
kernel-2.6.23.9-85.fc8


How reproducible:

with driver ath5k loaded, try command:  iwlist wlan0 scan

Steps to Reproduce:
1. install hardware PCI card D-Link WDA-2320 RangeBooster G Desktop Adapter
2. boot F-8 kernel-2.6.23.9-85.fc8
3. run command at shell prompt:  iwlist wlan0 scan
  
Actual results:
wlan0     No scan results

 (having 2 APs within range)


Expected results: (from another computer in the same room)
ath0      Scan completed :
          Cell 01 - Address: 00:13:46:B8:68:44
                    ESSID:"cuervo73"
                    Mode:Master
                    Frequency:2.427 GHz (Channel 4)
                    Quality=54/70  Signal level=-41 dBm  Noise level=-95 dBm
                    Encryption key:on
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 6 Mb/s
                              12 Mb/s; 24 Mb/s; 36 Mb/s; 9 Mb/s; 18 Mb/s
                              48 Mb/s; 54 Mb/s
                    Extra:bcn_int=100
                    IE: WPA Version 1
                        Group Cipher : WEP-40
                        Pairwise Ciphers (1) : WEP-40
                        Authentication Suites (1) : PSK
          Cell 02 - Address: 00:06:25:BF:DB:21
                    ESSID:""
                    Mode:Master
                    Frequency:2.412 GHz (Channel 1)
                    Quality=176/70  Signal level=-175 dBm  Noise level=-95 dBm
                    Encryption key:off
                    Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s
                    Extra:bcn_int=100


Additional info:

This worked with madwifi-0.9.3.3 under Fedora 8 Test 3

This may be an "ath5k" kernel driver issue instead; not sure
Comment 1 johnnymack 2008-01-22 03:41:34 EST
Created attachment 292477 [details]
supporting data from lspci, dmesg, lsmod,
Comment 2 Dan Williams 2008-01-22 11:27:45 EST
kernel driver issue; not wireless tools I expect.
Comment 3 John W. Linville 2008-01-22 11:36:57 EST
Please confirm that the problem persists with later kernels:

   http://koji.fedoraproject.org/koji/buildinfo?buildID=31896
Comment 4 johnnymack 2008-01-22 14:17:55 EST
OK, I went to koji and pulled "kernel-2.6.23.14-111.fc8.i686.rpm", installed
that, rebooted, retried command:  iwlist wlan0 scan

No improvement... still fails same way.  See session snippet:

obdurate[101]# ifconfig
lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:933 errors:0 dropped:0 overruns:0 frame:0
          TX packets:933 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:1948240 (1.8 MiB)  TX bytes:1948240 (1.8 MiB)

virbr0    Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:29 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:5200 (5.0 KiB)

wlan0     Link encap:Ethernet  HWaddr 00:1B:11:C9:29:08  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

wmaster0  Link encap:UNSPEC  HWaddr
00-1B-11-C9-29-08-08-14-00-00-00-00-00-00-00-00  
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

obdurate[102]# iwlist wlan0 scan
wlan0     No scan results

obdurate[103]# uname -a
Linux obdurate.egf-net 2.6.23.14-111.fc8 #1 SMP Thu Jan 17 18:18:57 EST 2008
i686 athlon i386 GNU/Linux
obdurate[104]# 
Comment 5 Dan Williams 2008-01-23 07:26:01 EST
Does the AP show up if you do three or four 'iwlist wlan0 scan' commands?  It's
not expected that every AP will show up every scan, just because that's the way
wireless works.  If you don't get the AP after three or four consecutive iwlist
scans, then there's likely some issue (power calibration, whatever).
Comment 6 johnnymack 2008-01-24 02:04:22 EST
Yes, I have tried that 7, 8, 9 times, in fact.  I am aware that when
scanning, not every station shows up on every scan.  I see this all the
time using a Toshiba laptop on the road.

But, this equipment is setup all in the same 11'X 10' room now: 

1) a Toshiba laptop with the D-Link DWL-G650 cardbus adapter. a working box
   running Fedora 6 with madwifi-0.9.3.3.  The expected results shown above in
   the "opened by.." remarks are iwlist scan results from this system.

2) an AMD 2100+ box with the D-Link WDA-2320 adapter.  the failing box which
   has F-8 installed and fails EVERY time iwlist scans.  But, this same h/w
   has F-7.92 installed on another partition with madwifi-0.9.3.3.
   When F-7.92 is booted up, this same hardware will run the WDA-2320 adapter
   wireless configuration connecting perfectly with the DI-624 [well, after
   hacking around a broken NM; I have my own script combining: ifconfig,
   iwlist/scan, iwconfig, wpa_supplicant, dhclient, route/add ]

3) a D-Link DI-624 wireless router.  working for last 24 months; using WPA-PSK
   for the last 6.

What else can I conclude?  

F-8    has "ath5k" only
F-7.92 has madwifi-0.9.3.3 [installed locally from tarball]  

wireless-tools-29-0.2.pre22 on F-8
wireless-tools-29           on F-7.92

With the testing of the equipment that I have, using other versions
of Fedora, I conclude it's unlikely to be a hardware issue.. on either the
WDA-2320 or the DI-624.

jm
Comment 7 John W. Linville 2008-01-24 15:07:10 EST

*** This bug has been marked as a duplicate of 420041 ***

Note You need to log in before you can comment on or make changes to this bug.