Bug 420631 - kcron silent option is broken
kcron silent option is broken
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kdeadmin (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-11 17:08 EST by Jeff Bastian
Modified: 2008-05-17 18:23 EDT (History)
3 users (show)

See Also:
Fixed In Version: F8-update
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-14 11:18:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
upstream patch to remove silent option (tested on RHEL 5.1) (3.93 KB, patch)
2007-12-11 17:08 EST, Jeff Bastian
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 85425 None None None Never

  None (edit)
Description Jeff Bastian 2007-12-11 17:08:53 EST
+++ This bug was initially created as a clone of Bug #420591 +++

Description of problem:
When creating a new cron job with kcron, there's a checkbox to make the job
silent.  If you enable the silent option, kcron fails with a generic error:
  An error occurred while updating crontab.

Launch kcron from a terminal and this error appears when saving the job:
  "/tmp/kde-user/kcrondR2FDb.tmp":2: bad minute
  errors in crontab file, can't install.

The problem is that kcron tries to insert a '-' before the minutes field to make
the job silent (apparently this is an extension for some flavors of cron). 
I.E., the line it creates looks like
  -1 2 3 4 5 /usr/bin/something

This has been reported upstream and the silent option has been removed.
  http://bugs.kde.org/show_bug.cgi?id=85425


Version-Release number of selected component (if applicable):
  kdeadmin-3.5.8-1.fc8

How reproducible:
Everytime

Steps to Reproduce:
1. Launch kcron
2. Create a new job and enable the Silent check box
3. Save
  
Actual results:
An error occurred while updating crontab.

Expected results:
Remove the Silent option from kcron as was done upstream.

Additional info:

-- Additional comment from jbastian@redhat.com on 2007-12-11 17:01 EST --
Created an attachment (id=284691)
upstream patch to remove silent option from kcron

I've tested this patch on RHEL 5.1 and verified it removes the Silent option.

It also removes any offending leading '-' characters from legacy silent jobs.
Comment 1 Jeff Bastian 2007-12-11 17:08:53 EST
Created attachment 284701 [details]
upstream patch to remove silent option (tested on RHEL 5.1)
Comment 2 Ngo Than 2008-05-14 11:18:35 EDT
it's fixed in kdeadmin-3.5.9-2. thanks
Comment 3 Fedora Update System 2008-05-14 12:20:06 EDT
kdeadmin-3.5.9-2.fc8 has been submitted as an update for Fedora 8
Comment 4 Kevin Kofler 2008-05-14 12:25:16 EDT
This affects F7 too, shouldn't we update that too?

F9+ is not affected, this has been fixed in 4.0.0.
Comment 5 Fedora Update System 2008-05-17 18:23:49 EDT
kdeadmin-3.5.9-2.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.