Bug 420781 - R help.start() java search applet does not work in Firefox with IcedTea
R help.start() java search applet does not work in Firefox with IcedTea
Status: CLOSED DUPLICATE of bug 304021
Product: Fedora
Classification: Fedora
Component: java-1.7.0-icedtea (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Fitzsimmons
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-11 19:01 EST by Marc Schwartz
Modified: 2007-12-12 13:30 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-12 13:30:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Marc Schwartz 2007-12-11 19:01:18 EST
Description of problem:

Within an R (http://www.r-project.org/) console, one can type:


to initiate a Firefox session with R help resources. On the initial HTML page,
there is a link for a search engine, to enable users to perform a keyword search
of R functions, etc. The search is enabled by a java applet.

It appears that the applet is non-functional using the default IcedTea JVM
installed on F8.

This has been referenced on the FC user list:


with a possible solution, using the Sun JRE, posted by me here:


In addition, there is a more general and recent entry in the FedoraFAQ regarding
getting Firefox java applets to function properly:


Unlike, my perhaps more extreme approach, the above allows for both the Sun JRE
and IcedTea to remain in parallel.

Finally, Knute Johnson, who participated in the FC list thread above, has
created the following page with his own approach, also resulting in a parallel
Sun/IcedTea installation:


The 'sed' step on his page appears to be no longer required, with the recent
libxcb update to 1.0-4.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:

See above

Actual results:

The java based search applet does not initialize to enable keyword searches

Expected results:

The java based search applet should initialize (noted on the Firefox status bar)
and enable keyword searches
Comment 1 Lillian Angel 2007-12-12 13:30:42 EST
It works, but it uses javascript. JavaScript is not yet implemented in IcedTea

*** This bug has been marked as a duplicate of 304021 ***

Note You need to log in before you can comment on or make changes to this bug.