Bug 42131 - rhn_register fails after typing username and password
rhn_register fails after typing username and password
Status: CLOSED DUPLICATE of bug 37913
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Registration (Show other bugs)
unspecified
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Cristian Gafton
Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-05-24 09:14 EDT by Need Real Name
Modified: 2015-01-07 18:45 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-24 09:14:10 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-05-24 09:14:06 EDT
From Bugzilla Helper:

User-Agent: Mozilla/4.0 (compatible; MSIE 5.1b1; Mac_PowerPC)



Description of problem:

After typing username and password to create a new account I get 
the following:



Traceback (innermost last):

  File "/usr/sbin/rhn_register", line 119, in ?

    main()

  File "/usr/sbin/rhn_register", line 100, in main

    tui.main()

  File "/usr/share/rhn/register/tui.py", line 1033, in main

    tui.run()

  File "/usr/share/rhn/register/tui.py", line 982, in run

    win = self.windows[index](self.screen, self)

  File "/usr/share/rhn/register/tui.py", line 422, in __init__

    self.emailContactButton.setValue("*")

AttributeError: setValue



Similar error when entering the account information for an existing 
account.



Using 

rhn_register-1.3.2-0.6.x



in --nox mode on a RedHat 6.2 system with the packages the RedHat 
Network site tells are needed upgraded.



How reproducible:

Always



Steps to Reproduce:

For me it's just running rhn_register; enter login, password (twice) 
and email address. Then on pressing "Next" the error above occurs.



Actual Results:  rhn_register crashed with the following:



Traceback (innermost last):

  File "/usr/sbin/rhn_register", line 119, in ?

    main()

  File "/usr/sbin/rhn_register", line 100, in main

    tui.main()

  File "/usr/share/rhn/register/tui.py", line 1033, in main

    tui.run()

  File "/usr/share/rhn/register/tui.py", line 982, in run

    win = self.windows[index](self.screen, self)

  File "/usr/share/rhn/register/tui.py", line 422, in __init__

    self.emailContactButton.setValue("*")

AttributeError: setValue



Expected Results:  that it kept running? :-)



Additional info:
Comment 1 David M. Cook 2001-05-24 14:54:14 EDT

*** This bug has been marked as a duplicate of 37913 ***

Note You need to log in before you can comment on or make changes to this bug.