Bug 422651 - cups-pdf fails to properly install or update when selinux is disabled
cups-pdf fails to properly install or update when selinux is disabled
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: cups-pdf (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Remi Collet
Fedora Extras Quality Assurance
:
: 422901 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 17:58 EST by Thomas Müller
Modified: 2008-05-31 01:22 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-31 01:22:47 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Müller 2007-12-12 17:58:52 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.11) Gecko/20071127 Firefox/2.0.0.11

Description of problem:
I have disabled selinux using the kernel parameter 'selinux=0'.

When I try to install or update cups-pdf the install/update scripts fails to configure the selinux settings because selinux is disabled.

Version-Release number of selected component (if applicable):
cups-pdf-2.4.6-6.fc8

How reproducible:
Always


Steps to Reproduce:
1. disable selinux
2. install or update cups-pdf

Actual Results:
Updating to cups-pdf-2.4.6-6.fc8 produced:
libsepol.permission_copy_callback: Module cups_pdf depends on permission setkeycreate in class process, not satisfied
libsemanage.semanage_link_sandbox: Link packages failed
semodule:  Failed!
cut: Schreibfehler: Datenübergabe unterbrochen (broken pipe)

Expected Results:
Install/update scripts should detect that selinux is disabled and exit gracefully

Additional info:
Comment 1 Remi Collet 2007-12-13 00:56:45 EST
*** Bug 422901 has been marked as a duplicate of this bug. ***
Comment 2 Remi Collet 2007-12-13 01:26:16 EST
You're right, semodule fails, but cups-pdf is installed and you have a working
CUPS-Pdf printer defined.

Full output of yum update cups-pdf :
--- 
  Installing: cups-pdf                     ######################### [1/1] 
libsepol.print_missing_requirements: cups_pdf's global requirements were not
met: type/attribute unconfined_home_t
libsemanage.semanage_link_sandbox: Link packages failed
semodule:  Failed!
cut: write error: Broken pipe

Installed: cups-pdf.x86_64 0:2.4.6-6.fc7
---

The post install scriplet handle this failure (semodule ... || true)

I don't think redirecting the error to /dev/null is a good idea.

Please confirm is the virtual printer is working.


Comment 3 Thomas Müller 2007-12-13 02:03:22 EST
Yes, the virtual printer is working fine. I should have stated this in my
initial report, sorry.

It's just unsettling to get error messages when installing a package. :)

Your are right, just redirecting to /dev/null will probably hide real errors on
systems with selinux enabled.
But wouldn't it be possible to detect if selinux is disabled and then just skip
this part?
Comment 4 Remi Collet 2008-05-31 01:22:47 EDT
This problem is fixed in latest version (No more SElinux stuff, policy handle by
main selinux package).

Note You need to log in before you can comment on or make changes to this bug.