Bug 422751 - no audio after suspend/resume
no audio after suspend/resume
Status: CLOSED DUPLICATE of bug 384271
Product: Fedora
Classification: Fedora
Component: pulseaudio (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Lubomir Rintel
Fedora Extras Quality Assurance
:
: 422311 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 20:30 EST by Bryan Che
Modified: 2009-01-07 13:09 EST (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 12:54:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
pulseaudio -vvv output (7.90 KB, text/plain)
2007-12-23 10:21 EST, Julian Sikorski
no flags Details

  None (edit)
Description Bryan Che 2007-12-12 20:30:56 EST
Description of problem:
After I did a recent yum update of my Lenovo T60, when I do a suspend/resume on
my laptop, I have sound after I resume.  If I kill X and login again, sound is
back.  Previous to this update, sound worked after a suspend/resume.

Version-Release number of selected component (if applicable):
pulseaudio-0.9.7-0.17.svn20071017.fc8

How reproducible:
very

Steps to Reproduce:
1.suspend
2.resume
3.
  
Actual results:
no sound

Expected results:
sound works

Additional info:
Comment 1 Julian Sikorski 2007-12-16 05:39:16 EST
I am not sure if this is related to pulseaudio, but Fedora 7 definitely did not
have such problem. Looks like the default audio device disappears:
alsamixer: function snd_ctl_open failed for default: No such device
Note that I don't have alsa-plugins-pulseaudio installed. Also, this does not
happen for me every time. Quite often, though.
Comment 2 krlynch 2007-12-17 14:48:00 EST
Same hardware, same problem.   For me, it is also intermittent, but somewhat
over half the wakeups fail.

I can make the problem "go away" by either logging out, or switching to a new
user (using the "fast-user-switch-applet"), logging out that user, and switching
back to the primary user.  The primary user now has sound again.  This
workaround has succeeded in roughly 10/10 tries.
Comment 3 Lubomir Kundrak 2007-12-20 06:40:41 EST
*** Bug 422311 has been marked as a duplicate of this bug. ***
Comment 4 Lubomir Kundrak 2007-12-20 09:46:09 EST
Could you please attach ouptut of "pulseaudio -vvv"?

Do this
# Kill the existing pulseaudio daemon
$ pulseaudio -k
# Get the log
$ pulseaudio -vvv 2>&1 |tee log

Comment 5 Mauricio Pretto 2007-12-22 05:14:20 EST
Hello there
since last fedora updates the problem isn't happening here anymore .
Comment 6 Julian Sikorski 2007-12-23 10:21:10 EST
Created attachment 290305 [details]
pulseaudio -vvv output

Here you go.
Comment 7 Matt Britt 2008-01-07 18:46:09 EST
*sigh* Same problem, same symptoms.  Also intermittent..  I can't really
reproduce it by trying, but it will invariably happen during normal use (several
suspends/resumes in a day).  The log file I got from pulseaudio is very similar
to the one attached above.  My hardware is intel8x0.
Comment 8 Matt Britt 2008-01-07 18:47:20 EST
(In reply to comment #7)
> *sigh* Same problem, same symptoms.  Also intermittent..  I can't really
> reproduce it by trying, but it will invariably happen during normal use (several
> suspends/resumes in a day).  The log file I got from pulseaudio is very similar
> to the one attached above.  My hardware is intel8x0.

I forgot to mention, restarting hald "fixes" the problem for me, though I might
as well just restart the computer at that point.
Comment 9 Tomas Mraz 2008-01-09 17:29:48 EST
This is much rather ConsoleKit/hald problem than pulseaudio.
Comment 10 Markus Berg 2008-01-10 05:15:48 EST
I'm having the same problem, intermittently.  I'm using a home built system
(Asus A8N nVidia-based motherboard with built-in sound) with Fedora 9 x86_64.

My workaround is this:
1. fuser -k /dev/snd/*
2. rmmod snd_hda_intel
3. modprobe snd_hda_intel
4. restart pulseaudio as the current user.

This workaround has worked every time except one.  That time I rmmod/modprobed
all snd-modules down to soundcore, and after that it worked.
Comment 11 Markus Berg 2008-01-10 05:23:38 EST
Sorry for the spam, typo in my previous comment.  That should be "Fedora 8 x86_64".
Comment 12 Julian Sikorski 2008-01-22 13:50:45 EST
Indeed, service haldaemon restart brings the sound back. So does switching to
vt1 for a moment and then back to X. Apparently, reloading sound modules also
helps. Since this issue is quite annoying, and looks like stalled, I'm CCing hal
and ConsoleKit maintainer.
Comment 13 Michel Alexandre Salim 2008-01-28 18:24:19 EST
The interesting thing is, immediately after resuming,

`ps x | grep pulse` shows nothing, but trying to restart pulseaudio results in
the claim that pulseaudio is already running.

pulseaudio --kill then wipes my entire notification area. I guess restarting
haldaemon is the less painful way of getting sound back.
Comment 14 Lubomir Kundrak 2008-02-28 12:54:06 EST
Fixing hal would be also one way to avoid pain...

*** This bug has been marked as a duplicate of 384271 ***

Note You need to log in before you can comment on or make changes to this bug.