Bug 422761 - Selinux stops hpijs from printing
Selinux stops hpijs from printing
Status: CLOSED DUPLICATE of bug 419191
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Tim Waugh
:
: 423051 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-12 20:39 EST by Guy Albertelli
Modified: 2007-12-13 08:13 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 08:13:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Guy Albertelli 2007-12-12 20:39:58 EST
Description of problem:
Upgraded FC7 on 12/11 using yum. Afterwards cannot print. Was working before.
Failure to print accompanied by selinux audit message

selinux audit message: 
avc: denied { getattr } for comm="sh" dev=dm-0 egid=7 euid=4 exe="/bin/bash"
exit=-13 fsgid=7 fsuid=4 gid=7 items=0 name="hpijs" path="/usr/bin/hpijs"
pid=5458 scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 sgid=7
subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 suid=4 tclass=file
tcontext=system_u:object_r:hplip_exec_t:s0 tty=(none) uid=4 

Version-Release number of selected component (if applicable):
Failing:
  hpijs-1.7.4a-6.fc7
  selinux-policy-targeted-2.6.4-61.fc7
Working
  hpijs-1.7.4a-6.fc7
  selinux-policy.noarch 2.6.4-48.fc7

How reproducible:
Attempt to print test page to printer

Steps to Reproduce:
1. Invoke Printer configuration utility
2. Attempt to print test page
3.
  
Actual results:
Audit message added to selinux log

Expected results:
Test page printed

Additional info:
Setting selinux to "permissive" allows printing to work and still generates the
audit log entry.
Comment 1 Tim Waugh 2007-12-13 07:27:10 EST
*** Bug 423051 has been marked as a duplicate of this bug. ***
Comment 2 Tim Waugh 2007-12-13 08:13:14 EST

*** This bug has been marked as a duplicate of 419191 ***

Note You need to log in before you can comment on or make changes to this bug.