Bug 423051 - SELinux is preventing sh (cupsd_t) "getattr" to /usr/bin/hpijs (hplip_exec_t)
SELinux is preventing sh (cupsd_t) "getattr" to /usr/bin/hpijs (hplip_exec_t)
Status: CLOSED DUPLICATE of bug 422761
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 05:19 EST by Peter Beutel
Modified: 2007-12-13 07:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-13 07:27:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Beutel 2007-12-13 05:19:49 EST
output of setroubleshoot browser:

SELinux denied access requested by sh. It is not expected that this access is
required by sh and this access may signal an intrusion attempt. It is also
possible that the specific version or configuration of the application is
causing it to require additional access.

Additional InformationSource
Context:  system_u:system_r:cupsd_t:SystemLow-SystemHighTarget
Context:  system_u:object_r:hplip_exec_tTarget Objects:  /usr/bin/hpijs [ file
]Affected RPM Packages:  hpijs-1.7.4a-6.fc7 [target]Policy
RPM:  selinux-policy-2.6.4-61.fc7Selinux Enabled:  TruePolicy Type:  targetedMLS
Enabled:  TrueEnforcing Mode:  EnforcingPlugin Name:  plugins.catchall_fileHost
Name:  blobbPlatform:  Linux blobb 2.6.23.8-34.fc7 #1 SMP Thu Nov 22 23:05:33
EST 2007 i686 i686Alert Count:  6First Seen:  Mi 12 Dez 2007 15:45:50 CETLast
Seen:  Do 13 Dez 2007 10:11:55 CETLocal
ID:  c246f009-4493-46f9-b46b-8e00d76c0cd9Line Numbers:  Raw Audit Messages :avc:
denied { getattr } for comm="sh" dev=dm-0 egid=7 euid=4 exe="/bin/bash" exit=-13
fsgid=7 fsuid=4 gid=7 items=0 path="/usr/bin/hpijs" pid=3627
scontext=system_u:system_r:cupsd_t:s0-s0:c0.c1023 sgid=7
subj=system_u:system_r:cupsd_t:s0-s0:c0.c1023 suid=4 tclass=file
tcontext=system_u:object_r:hplip_exec_t:s0 tty=(none) uid=4
Comment 1 Tim Waugh 2007-12-13 07:27:09 EST

*** This bug has been marked as a duplicate of 422761 ***

Note You need to log in before you can comment on or make changes to this bug.