Bug 423011 - busybox cut command suppresses redirected output
busybox cut command suppresses redirected output
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: busybox (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
Depends On:
Blocks: 399731 425873
  Show dependency treegraph
 
Reported: 2007-12-13 04:34 EST by D. Hugh Redelmeier
Modified: 2008-02-28 03:54 EST (History)
1 user (show)

See Also:
Fixed In Version: busybox-1.2.2-10.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-28 03:54:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
demonstration / exploration of busybox's cut behaviour (582 bytes, text/plain)
2007-12-13 04:34 EST, D. Hugh Redelmeier
no flags Details

  None (edit)
Description D. Hugh Redelmeier 2007-12-13 04:34:57 EST
Description of problem:
a cut command that works when output goes to the console but produces no output
otherwise

Version-Release number of selected component (if applicable):
busybox-1.2.2-8.fc7

How reproducible:
always

Steps to Reproduce:
see attached log
  
Actual results:
cut produces an empty file

Expected results:
cut produces a file with "1"

Additional info:
This seems to be why kdump is currently broken, at least for me.  See
https://bugzilla.redhat.com/show_bug.cgi?id=399731
Comment 1 D. Hugh Redelmeier 2007-12-13 04:34:57 EST
Created attachment 287111 [details]
demonstration / exploration of busybox's cut behaviour
Comment 2 Ivana Varekova 2007-12-13 11:06:32 EST
This problem is fixed in busybox-1.2.2-9.fc7 which will be in test branch soon.
Comment 3 D. Hugh Redelmeier 2007-12-14 12:37:24 EST
I think that means it will appear in
http://download.fedora.redhat.com/pub/fedora/linux/updates/testing/7/x86_64/
It's not there yet.
The busybox site lists 1.8.2 as the latest stable version. 1.2.2 dates back to
October 2006.

F8 uses 1.6.1 (2007 June) as a base.  It does not have this bug nor does it have
https://bugzilla.redhat.com/show_bug.cgi?id=423781 .  Would it be good to rebase
to 1.6.1?
Comment 4 Fedora Update System 2007-12-15 12:50:05 EST
busybox-1.2.2-9.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update busybox'
Comment 5 D. Hugh Redelmeier 2007-12-15 23:04:08 EST
This version seems to fix the cut bug.  kdump now works.  Thanks.
Comment 6 D. Hugh Redelmeier 2007-12-16 21:32:07 EST
clone for F8's busybox 1.6.1: bug 425873

Note You need to log in before you can comment on or make changes to this bug.