Bug 423371 - Insert file of a spreadsheet into a document crashes oowriter
Insert file of a spreadsheet into a document crashes oowriter
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Caolan McNamara
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-13 08:21 EST by Alan Cox
Modified: 2008-01-22 10:42 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.3.0-6.11.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-01-22 10:42:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
mapped stack (4.25 KB, text/plain)
2007-12-13 10:39 EST, Caolan McNamara
no flags Details
reproducer (95.50 KB, application/vnd.ms-excel)
2007-12-16 08:31 EST, Caolan McNamara
no flags Details

External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 84621 None None None Never

  None (edit)
Description Alan Cox 2007-12-13 08:21:42 EST
Description of problem:

Attempting to 'insert file' a spreadsheet into an oowriter document explodes

(example trace below with SELinux off)

Steps to Reproduce:
1. Create a writer doc with stuff in it
2. Insert file (*not* OLE object which is what I meant to do) a spreadsheet
3. Boom
Actual results:

Kerboom - trace below

Expected results:

An error dialog or an OLE type insert.

Additional info:
---start copy and paste here---
(I)    x.org loaded video driver of...
(II) Loading /usr/lib64/xorg/modules/drivers/radeon_drv.so
(II) Loading /usr/lib64/xorg/modules/drivers/ati_drv.so
(II) Reloading /usr/lib64/xorg/modules/drivers/radeon_drv.so
(--) Depth 24 pixmap format is 32 bpp
(III)  Desktop is: GNOME
(IV)   libgcj version is: libgcj-4.1.2-33-x86_64
(V)    kernel is: Linux 2.6.20-1.2962.fc6 #1 SMP Tue Jun 19 18:50:05 EDT 2007
x86_64 x86_64 x86_64
(VI)   OpenOffice.org core rpm version is: openoffice.org-core-2.3.0-6.6.fc8-x86_64
(VII)  accessibility is: false
(VIII) fedora release is: Fedora release 8 (Werewolf)
...start free space details ...
Filesystem           1K-blocks      Used Available Use% Mounted on  58845888  43384768  12471840  78% /home
/dev/sda2            191162012  28209972 153241552  16% /
...end free space details ...
...start sestatus details ...
SELinux status:                 disabled
...end sestatus details ...
...start stackreport details ...
0x00002aaaaf951a64: 0x00000000001ebbe8:
/usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x36a64
0x00002aaaaf95285a: 0x00000000001ebbe8:
/usr/lib64/openoffice.org/program/libuno_sal.so.3 + 0x3785a
0x00002aaaad2a9f30: 0x0000000000150b60: /lib64/libc.so.6 + 0x30f30
0x00002aaab22f51c4: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x1af1c4
(SfxObjectShell::IsInPlaceActive() + 0x4)
0x00002aaaab0730c7: 0x0000000000b8bbe8:
/usr/lib64/openoffice.org/program/libsw680lx.so + 0x3680c7
0x00002aaaaafeb318: 0x0000000000b8bbe8:
/usr/lib64/openoffice.org/program/libsw680lx.so + 0x2e0318
(ViewShell::ImplEndAction(unsigned char) + 0x868)
0x00002aaaaafc51b2: 0x0000000000b8bbe8:
/usr/lib64/openoffice.org/program/libsw680lx.so + 0x2ba1b2
(SwCrsrShell::EndAction(unsigned char) + 0x272)
0x00002aaaaafba82e: 0x0000000000b8bbe8:
/usr/lib64/openoffice.org/program/libsw680lx.so + 0x2af82e
(SwEditShell::EndAllAction() + 0x4e)
0x00002aaaab6b1a9a: 0x0000000000b8bbe8:
/usr/lib64/openoffice.org/program/libsw680lx.so + 0x9a6a9a
(SwView::InsertMedium(unsigned short, SfxMedium*, short) + 0x4ea)
0x00002aaaab6b1fde: 0x0000000000b8bbe8:
/usr/lib64/openoffice.org/program/libsw680lx.so + 0x9a6fde
(SwView::DialogClosedHdl(sfx2::FileDialogHelper*) + 0x7e)
0x00002aaab2385e21: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x23fe21
(sfx2::DocumentInserter::DialogClosedHdl(sfx2::FileDialogHelper*) + 0xe1)
0x00002aaab2439963: 0x00000000003f7d08:
/usr/lib64/openoffice.org/program/libsfx680lx.so + 0x2f3963
(sfx2::FileDialogHelper::ExecuteSystemFilePicker(void*) + 0x23)
0x00002aaaad877601: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0x2a7601
0x00002aaabefc6c8f: 0x00000000000818b0:
/usr/lib64/openoffice.org/program/libvclplug_gen680lx.so + 0x57c8f
(SalDisplay::DispatchInternalEvent() + 0xbf)
0x00002aaabe4aa029: 0x000000000004fe68:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x18029
0x00002aaab74eddf3: 0x00000000000c69b8: /lib64/libglib-2.0.so.0 + 0x2edf3
(g_main_context_dispatch + 0x1c3)
0x00002aaab74f10ed: 0x00000000000c69b8: /lib64/libglib-2.0.so.0 + 0x320ed
0x00002aaab74f161e: 0x00000000000c69b8: /lib64/libglib-2.0.so.0 + 0x3261e
(g_main_context_iteration + 0x6e)
0x00002aaabe4abab9: 0x000000000004fe68:
/usr/lib64/openoffice.org/program/libvclplug_gtk680lx.so + 0x19ab9
0x00002aaaad69ffce: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xcffce
(Application::Yield(bool) + 0x3e)
0x00002aaaad6a00a7: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd00a7
(Application::Execute() + 0x27)
0x00002aaaaaada05e: 0x000000000005b458:
/usr/lib64/openoffice.org/program/libsoffice.so + 0x2d05e
(desktop::Desktop::Main() + 0x13ae)
0x00002aaaad6a5864: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd5864
0x00002aaaad6a5955: 0x00000000003aefe8:
/usr/lib64/openoffice.org/program/libvcl680lx.so + 0xd5955 (SVMain() + 0x25)
0x00002aaaaaacc65e: 0x000000000005b458:
/usr/lib64/openoffice.org/program/libsoffice.so + 0x1f65e (main + 0xae)
0x00002aaaad297074: 0x0000000000150b60: /lib64/libc.so.6 + 0x1e074
(__libc_start_main + 0xf4)
0x0000000000400639: 0x0000000000000890:
/usr/lib64/openoffice.org/program/swriter.bin + 0x639 (main + 0x49)
...end stackreport details ...
...start sample ldd details ...
        libgtk-x11-2.0.so.0 => /usr/lib64/libgtk-x11-2.0.so.0 (0x00002aaaaad23000)
        libgdk-x11-2.0.so.0 => /usr/lib64/libgdk-x11-2.0.so.0 (0x00002aaaab312000)
        libatk-1.0.so.0 => /usr/lib64/libatk-1.0.so.0 (0x00002aaaab5b2000)
        libgdk_pixbuf-2.0.so.0 => /usr/lib64/libgdk_pixbuf-2.0.so.0
        libpangocairo-1.0.so.0 => /usr/lib64/libpangocairo-1.0.so.0
        libpango-1.0.so.0 => /usr/lib64/libpango-1.0.so.0 (0x00002aaaabbf8000)
        libcairo.so.2 => /usr/lib64/libcairo.so.2 (0x00002aaaabe3b000)
        libgmodule-2.0.so.0 => /lib64/libgmodule-2.0.so.0 (0x00002aaaac0b7000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00002aaaac2ba000)
        libgthread-2.0.so.0 => /lib64/libgthread-2.0.so.0 (0x00002aaaac4bf000)
        librt.so.1 => /lib64/librt.so.1 (0x00002aaaac6c3000)
        libdbus-glib-1.so.2 => /usr/lib64/libdbus-glib-1.so.2 (0x00002aaaac8cc000)
        libdbus-1.so.3 => /lib64/libdbus-1.so.3 (0x00002aaaacaec000)
        libgobject-2.0.so.0 => /lib64/libgobject-2.0.so.0 (0x00002aaaacd27000)
        libglib-2.0.so.0 => /lib64/libglib-2.0.so.0 (0x00002aaaacf68000)
        libvclplug_gen680lx.so =>
/usr/lib64/openoffice.org/program/libvclplug_gen680lx.so (0x00002aaaad231000)
        libvcl680lx.so => /usr/lib64/openoffice.org/program/libvcl680lx.so
        libpsp680lx.so => /usr/lib64/openoffice.org/program/libpsp680lx.so
        libsot680lx.so => /usr/lib64/openoffice.org/program/libsot680lx.so
        libutl680lx.so => /usr/lib64/openoffice.org/program/libutl680lx.so
        libtl680lx.so => /usr/lib64/openoffice.org/program/libtl680lx.so
        libcomphelp4gcc3.so =>
/usr/lib64/openoffice.org/program/libcomphelp4gcc3.so (0x00002aaaae517000)
        libucbhelper4gcc3.so =>
/usr/lib64/openoffice.org/program/libucbhelper4gcc3.so (0x00002aaaae851000)
        libuno_cppuhelpergcc3.so.3 =>
/usr/lib64/openoffice.org/program/libuno_cppuhelpergcc3.so.3 (0x00002aaaaeacf000)
        libuno_cppu.so.3 => /usr/lib64/openoffice.org/program/libuno_cppu.so.3
        libvos3gcc3.so => /usr/lib64/openoffice.org/program/libvos3gcc3.so
        libuno_sal.so.3 => /usr/lib64/openoffice.org/program/libuno_sal.so.3
        libX11.so.6 => /usr/lib64/libX11.so.6 (0x00002aaaaf5df000)
        libXext.so.6 => /usr/lib64/libXext.so.6 (0x00002aaaaf8e3000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00002aaaafaf4000)
        libstdc++.so.6 => /usr/lib64/libstdc++.so.6 (0x00002aaaafd10000)
        libm.so.6 => /lib64/libm.so.6 (0x00002aaab0010000)
        libgcc_s.so.1 => /lib64/libgcc_s.so.1 (0x00002aaab0293000)
        libc.so.6 => /lib64/libc.so.6 (0x00002aaab04a2000)
        libXfixes.so.3 => /usr/lib64/libXfixes.so.3 (0x00002aaab07f9000)
        libpng12.so.0 => /usr/lib64/libpng12.so.0 (0x00002aaab09fe000)
        libfontconfig.so.1 => /usr/lib64/libfontconfig.so.1 (0x00002aaab0c23000)
        libXrender.so.1 => /usr/lib64/libXrender.so.1 (0x00002aaab0e57000)
        libXinerama.so.1 => /usr/lib64/libXinerama.so.1 (0x00002aaab1060000)
        libXi.so.6 => /usr/lib64/libXi.so.6 (0x00002aaab1263000)
        libXrandr.so.2 => /usr/lib64/libXrandr.so.2 (0x00002aaab146c000)
        libXcursor.so.1 => /usr/lib64/libXcursor.so.1 (0x00002aaab1673000)
        libpangoft2-1.0.so.0 => /usr/lib64/libpangoft2-1.0.so.0 (0x00002aaab187d000)
        libfreetype.so.6 => /usr/lib64/libfreetype.so.6 (0x00002aaab1aae000)
        libz.so.1 => /lib64/libz.so.1 (0x00002aaab1d3e000)
        /lib64/ld-linux-x86-64.so.2 (0x0000555555554000)
        libnsl.so.1 => /lib64/libnsl.so.1 (0x00002aaab1f52000)
        libcap.so.1 => /lib64/libcap.so.1 (0x00002aaab216b000)
        libSM.so.6 => /usr/lib64/libSM.so.6 (0x00002aaab236e000)
        libICE.so.6 => /usr/lib64/libICE.so.6 (0x00002aaab2578000)
        libi18nisolang1gcc3.so =>
/usr/lib64/openoffice.org/program/libi18nisolang1gcc3.so (0x00002aaab2794000)
        libbasegfx680lx.so =>
/usr/lib64/openoffice.org/program/libbasegfx680lx.so (0x00002aaab2999000)
        libicuuc.so.38 => /usr/lib64/libicuuc.so.38 (0x00002aaab2c06000)
        libicule.so.38 => /usr/lib64/libicule.so.38 (0x00002aaab2f3e000)
        libjvmaccessgcc3.so.3 =>
/usr/lib64/openoffice.org/program/libjvmaccessgcc3.so.3 (0x00002aaab3173000)
        libjvmfwk.so.3 => /usr/lib64/openoffice.org/program/libjvmfwk.so.3
        libuno_salhelpergcc3.so.3 =>
/usr/lib64/openoffice.org/program/libuno_salhelpergcc3.so.3 (0x00002aaab3598000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00002aaab379d000)
        libxcb-xlib.so.0 => /usr/lib64/libxcb-xlib.so.0 (0x00002aaab39d5000)
        libxcb.so.1 => /usr/lib64/libxcb.so.1 (0x00002aaab3bd7000)
        libXau.so.6 => /usr/lib64/libXau.so.6 (0x00002aaab3df1000)
        libexpat.so.1 => /lib64/libexpat.so.1 (0x00002aaab3ff4000)
        libicudata.so.38 => /usr/lib64/libicudata.so.38 (0x00002aaab4217000)
        libxml2.so.2 => /usr/lib64/libxml2.so.2 (0x00002aaab4ec1000)
        libXdmcp.so.6 => /usr/lib64/libXdmcp.so.6 (0x00002aaab5200000)
...end sample ldd details ...
---end copy and paste here---
paste the above into your bug report
Comment 1 Caolan McNamara 2007-12-13 10:39:26 EST
Created attachment 287451 [details]
mapped stack
Comment 2 Caolan McNamara 2007-12-13 11:56:40 EST
Hmm, I don't get a a big crass immediate crash on insert->file...->select an
.ods (I assume it was an .ods and not a .xls) from inside writer with the x86_64
2.3.0-6.6.fc8 rpms. Will check tomorrow under valgrind.
Comment 3 Caolan McNamara 2007-12-14 04:48:36 EST
ok, that's very odd. InsertMedium should only be called for files that writer
itself can directly import, so can you either share with me the document that
you tried to insert->file with, or at least verify with "file" the format of the
to-be-inserted file. AFAICS a spreadsheet should just be ignored by writer with
no attempt to InsertMedium.
Comment 4 Alan Cox 2007-12-14 13:45:14 EST
I can provide you with both documents privately but not publically. Whats the
best way of doing that ?
Comment 5 Alan Cox 2007-12-14 13:46:22 EST
If its relevant btw the source document was odt the inserted object was a
microsoft excel spreadsheet
Comment 6 Caolan McNamara 2007-12-16 07:47:30 EST
Just mail it to me directly and I'll keep it confidential. Perhaps this is a old
format excel spreadsheet. IIRC there was an old "excel spreadsheet as text"
filter which might still have its dinosaur dna infecting the split out binfilter
which could explain this.
Comment 7 Caolan McNamara 2007-12-16 08:31:24 EST
Created attachment 289721 [details]

no need, found a excel 5 format .xls which triggers it
Comment 8 Caolan McNamara 2007-12-16 08:49:09 EST
fix will be in next devel spin and in next F-8 update if there is one as
openoffice.org >= 2.3.0-6.8
Comment 9 Alan Cox 2007-12-16 09:40:52 EST
Comment 10 Fedora Update System 2008-01-06 20:19:07 EST
openoffice.org-2.3.0-6.10.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'
Comment 11 Satyabrata Maitra 2008-01-14 07:11:31 EST
Attempted to test this bug...
I tried to update openoffice.org version via yum. But it given some error
accessing the repository. Please make me sure the following repository is Fedora
Testing repository...

Given error :-

su -c 'yum --enablerepo=updates-testing update openoffice.org'
[Errno 4] IOError: [Errno ftp error] 421 There are too many connected users,
please try later.
Trying other mirror.
fedora                    100% |=========================| 2.1 kB    00:00     
updates-testing           100% |=========================| 2.3 kB    00:00     
primary.sqlite.bz2        100% |=========================| 395 kB    00:26     
ftp://fedora.glug-nith.org/linux/updates/8/i386/repodata/repomd.xml: [Errno 4]
IOError: [Errno ftp error] 421 There are too many connected users, please try later.

Is there any other repository where I can get openoffice.org-2.3.0-6.10.fc8
version please? Inform pls. I can then test it. :)
Comment 12 Fedora Update System 2008-01-15 18:06:32 EST
openoffice.org-2.3.0-6.11.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update openoffice.org'
Comment 13 Fedora Update System 2008-01-22 10:41:54 EST
openoffice.org-2.3.0-6.11.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.