Bug 424171 - logwatch doesn't recognize dovecot starting up message with version number
logwatch doesn't recognize dovecot starting up message with version number
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: logwatch (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Ivana Varekova
Fedora Extras Quality Assurance
:
: 425973 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 15:44 EST by Gilles Detillieux
Modified: 2008-01-04 11:05 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-02 09:55:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to make logwatch 7.3.6's dovecot script recognize Dovecot startup with version number (691 bytes, patch)
2007-12-13 15:44 EST, Gilles Detillieux
no flags Details | Diff

  None (edit)
Description Gilles Detillieux 2007-12-13 15:44:39 EST
Description of problem:
Logwatch 7.3.6 handles dovecot 1.0 log entries for the most part, but fails to
properly recognize the "starting up" message, which now includes a version number.


Version-Release number of selected component (if applicable):
7.3.6-13.fc9 (rawhide)
7.3.6-11.fc8 (Fedora 8)


How reproducible:
Always


Steps to Reproduce:
1. Set up and start dovecot service on Fedora 8 or rawhide.
2. Login to service using IMAP or POP.
3. logwatch --range All --service dovecot --detail 10 --print
  
Actual results:
"dovecot: Dovecot v1.0.7 starting up: 1 Times(s)" appears under **Unmatched
Entries**


Expected results:
"Dovecot restarted 1 time(s)."


Additional info:
Patch below fixes problem. Patch also posted to Bug #424031 for RHEL 5.
Comment 1 Gilles Detillieux 2007-12-13 15:44:39 EST
Created attachment 287971 [details]
patch to make logwatch 7.3.6's dovecot script recognize Dovecot startup with version number
Comment 2 Ivana Varekova 2008-01-02 09:55:32 EST
Thanks, fixed in logwatch-7.3.6-15.fc9.
Comment 3 Tomas Janousek 2008-01-04 11:05:11 EST
*** Bug 425973 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.