Bug 424411 - Export to EPS opens print dialog
Export to EPS opens print dialog
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
8
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
: Reopened
: 426027 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 17:39 EST by Neal Becker
Modified: 2008-03-26 13:18 EDT (History)
5 users (show)

See Also:
Fixed In Version: 0.46-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:18:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot (35.13 KB, image/png)
2007-12-13 19:47 EST, Neal Becker
no flags Details

  None (edit)
Description Neal Becker 2007-12-13 17:39:59 EST
Description of problem:
I've tried various variations on:

inkscape --without-gui --export-eps=filelog.eps --file=filelog.svg

But it always opens a print dialog.  This isn't very helpful run from a 
Makefile.

Version-Release number of selected component (if applicable):
inkscape-0.45.1-4.fc8.x86_64

How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Denis Leroy 2007-12-13 18:37:50 EST
Hmm, works for me.

What if you "Save as..." manually into eps format, does that actually work ?

If you look at .inkscape/extension-errors.log, do you see anything related to PS
or EPS import/export ?
Comment 2 Neal Becker 2007-12-13 19:47:38 EST
Created attachment 288161 [details]
screen shot
Comment 3 Denis Leroy 2007-12-13 19:53:24 EST
This with inkscape-0.46-0.svn16571.fc8 ?

And you can reproduce with any SVG document, even something really simple ?
Comment 4 Neal Becker 2007-12-13 20:03:29 EST
inkscape-0.45.1-4.fc8.x86_64

I can reproduce it with a completely blank document, after starting inkscape, 
and just doing save as eps!
Comment 5 Denis Leroy 2007-12-13 20:09:33 EST
Ah sorry, I forgot I had an experimental version installed. I reinstalled the
current F-8 update, and I can reproduce the bug now.

Well it looks as though this is fixed upstream. We were thinking about pushing a
0.46 svn update eventually, at least to rawhide. I'll try to look up that patch
from subversion.

If you need an urgent fix, you can compile
http://www.poolshark.org/src/inkscape-0.46-0.svn16571.fc8.src.rpm
Comment 6 Denis Leroy 2007-12-17 17:02:48 EST
*** Bug 426027 has been marked as a duplicate of this bug. ***
Comment 7 Pete Wyckoff 2008-01-07 21:56:22 EST
Would definitely appreciate an F-8 update fix.  This
severly impacts our document workflows, and has been
broken for almost a month now.
Comment 8 Bryan O'Sullivan 2008-01-07 22:14:24 EST
Likewise.  I can't build my book on F-8 because of this.
Comment 9 Denis Leroy 2008-01-08 09:16:47 EST
Ok I wrote a fix for this. Should be available in updates-testing shortly.
Comment 10 Fedora Update System 2008-01-11 17:00:33 EST
inkscape-0.45.1-5.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update inkscape'
Comment 11 Pete Wyckoff 2008-01-16 10:44:51 EST
0.45.1-5.fc8 on x86_64 fixes the problem, thanks.
Comment 12 Fedora Update System 2008-01-22 10:53:34 EST
inkscape-0.45.1-5.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 13 william hanlon 2008-02-06 21:36:52 EST
I have retrived inkscape-0.45.1-5.fc8-i386 and the problem still exists for me.

Comment 14 Lubomir Kundrak 2008-02-07 03:14:22 EST
Reopening. Could reproduce on inkscape-0.45.1-5.fc8.i386 (attempt to save empty
drawing as EPS). Could not reproduce on 0.46 prerelease [1], so probably some
more bits need backporting -- will look at it later.

[1] http://koji.fedoraproject.org/koji/taskinfo?taskID=400681
Comment 15 Lubomir Kundrak 2008-02-13 21:39:29 EST
I won't backport the fix. Prerelease of inkscape 0.46 will hit testing soon and
once 0.46 stable is out (assuming no issues with testing one arise), it will be
pushed to Fedora 8.
Comment 16 Fedora Update System 2008-02-13 22:25:13 EST
inkscape-0.45.1+0.46pre1-3.fc8 has been submitted as an update for Fedora 8
Comment 17 Fedora Update System 2008-02-15 21:06:02 EST
inkscape-0.45.1+0.46pre1-4.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update inkscape'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-1718
Comment 18 Nicu Buculei 2008-03-13 04:31:36 EDT
I can't reproduce the bug with inkscape-0.46-0.2.pre3.fc8.
I think it can be closed.
Comment 19 Denis Leroy 2008-03-13 05:18:14 EDT
Thanks Nicu,
Comment 20 Lubomir Kundrak 2008-03-13 05:57:51 EDT
Oh no, guys, what have you done! Now bodhi can not close that and it will be
sad. I promised it it can close bugs this time as it was doing its homeworks
responsibly for the whole month now! :(
Comment 21 Denis Leroy 2008-03-13 06:05:07 EDT
Ah but can bodhi VERIFY that the bug is indeed fixed ? :-)
Comment 22 Lubomir Kundrak 2008-03-13 06:50:35 EDT
No, dirty work is left on humans.
Comment 23 Fedora Update System 2008-03-26 13:18:45 EDT
inkscape-0.46-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.