Bug 426027 - inkscape doesn't save eps files
inkscape doesn't save eps files
Status: CLOSED DUPLICATE of bug 424411
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-17 16:09 EST by william hanlon
Modified: 2007-12-17 17:02 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-17 17:02:47 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description william hanlon 2007-12-17 16:09:34 EST
Description of problem:
When trying to save an inkscape generated file into eps or ps format, inkscape
no longer saves the files. Instead it opens the "print" dialog window. There is
no way to directly save to eps format anymore. This feature was available in the
last version (pre 0.45.1-4.fc8)

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. generate a file in inkscape
2. Click "File", "Save" or "Save As" or "Save a copy"
3. In the "Select File" dialog window, choose the file type to save as
"Encapsulated Postscript (*.eps)" or "Postscript (*.ps)".
4. Choose a file name to save as.
5. Click "Save".
6. Set whatever options are desired in the "output" dialog window.
7. Click "OK".
8. In previous versions, the eps or ps file would then be saved to disk, now
instead the "Print" dialog window opens.
Actual results:
The file is not saved to disk, instead inkscape tries to send it to the printer.

Expected results:
The file should be saved to disk in the desired format.

Additional info:
The "Print" dialog window offers the option to print to a file. But the only
formats it supports is ps and pdf. If one wishes to get eps, they could print to
a ps file, then use ps2eps to get the eps output. In my experience, it's usually
better to have the native application write the eps output though, so the old
behavior of letting inkscape generate its own eps is preferred.

The version of inkscape just prior to the one listed in this bug report worked
as it should, i.e., it saved eps files without invoking the "print" window.
Comment 1 Denis Leroy 2007-12-17 17:02:47 EST
It's fixed upstream. We'll try to patch this for f-8.

*** This bug has been marked as a duplicate of 424411 ***

Note You need to log in before you can comment on or make changes to this bug.