Bug 424421 - Xen Domain crashes when installing DomU via anaconda
Xen Domain crashes when installing DomU via anaconda
Status: CLOSED DUPLICATE of bug 250427
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.1
All Linux
low Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Virtualization Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-13 18:13 EST by Andreas Thienemann
Modified: 2009-12-14 16:25 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 09:31:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xend.log (143.73 KB, text/plain)
2007-12-14 02:49 EST, Andreas Thienemann
no flags Details
kernel trace (22.30 KB, image/png)
2007-12-14 09:37 EST, Andreas Thienemann
no flags Details

  None (edit)
Description Andreas Thienemann 2007-12-13 18:13:50 EST
Description of problem:
When installing a 32bit DomU on a x86_64 Dom0 the DomU crashed repeatedly.

Version-Release number of selected component (if applicable):
Fresh RHEL5.1 install.

How reproducible:
Always

Steps to Reproduce:
1. xm create staging kernel=/var/lib/xen/bootstrap/i386/vmlinuz
ramdisk=/var/lib/xen/bootstrap/i386/initrd.img bootloader="" extra="ip=
10.32.4.66 netmask=255.255.255.0 dns=10.32.63.5 gateway=10.32.4.254
method=http://file/rhel5 ks=http://file/ks-small.cfg lang=en_US
keymap=de-latin1-nodeadkeys text" on_crash=preserve on_reboot=destroy
2. Wait and watch via vncviewer localhost:1
3. Domain crashes during package installation
  
Actual results:
Domain crashes

Expected results:
Domain installed

Additional info:
Rebooting the Dom0 seems to make one install run possible. A second install fails.

The log doesn't show very much:

[2007-12-13 23:56:50 xend.XendDomainInfo 3234] WARNING (XendDomainInfo:923)
Domain has crashed: name=staging id=5.
[2007-12-13 23:56:50 xend.XendDomainInfo 3234] INFO (XendDomainInfo:1886)
Preserving dead domain staging (5).


Any suggestions on debugging this?
Comment 1 Daniel Berrange 2007-12-13 19:40:12 EST
a) use virt-install/virt-manager instead of xm and attach the
/root/.virtinst/*.log files or /root/.virt-manager/*log files if any are created
b) give the domain enough memory - xen defaults to '128' which is not enough for
anaconda - it'll crash & burn with this little
c) attach the *full*  /var/log/xen/xend.log
d) Do *not* use a 32-bit paravirt DomU on a 64-bit Dom0 - this is known to
randomly crash.
Comment 2 Andreas Thienemann 2007-12-14 02:47:56 EST
(In reply to comment #1)
> a) use virt-install/virt-manager instead of xm and attach the
> /root/.virtinst/*.log files or /root/.virt-manager/*log files if any are 
> created
gonna try that

> b) give the domain enough memory - xen defaults to '128' which is not enough 
> for anaconda - it'll crash & burn with this little
The domain had 1024M assigned via the config file

> c) attach the *full*  /var/log/xen/xend.log
Done

> d) Do *not* use a 32-bit paravirt DomU on a 64-bit Dom0 - this is known to
> randomly crash.
Urgh. Fixes in sight?
Comment 3 Andreas Thienemann 2007-12-14 02:49:36 EST
Created attachment 288661 [details]
xend.log
Comment 4 Andreas Thienemann 2007-12-14 02:52:24 EST
An additional note to b) Anaconda does usually just seem to freeze, no messages
at all.
Some times however, I can see some remnants of /dev/ram0 or something similar
written on the console.
Comment 5 Daniel Berrange 2007-12-14 09:31:10 EST
This is all symptomatic of running a 32-bit guest on a 64-bit HV. We know this
doesn't work in 5.1 and we can't fix it - we don't even know why its broken - it
simply doesn't work. It may work in 5.2 - we won't know until we try the full QA
cycle on it though.
Comment 6 Andreas Thienemann 2007-12-14 09:36:46 EST
Hi Daniel,

I've got a bit more info, reconnecting the vnc viewer gives some trace information.
Comment 7 Andreas Thienemann 2007-12-14 09:37:14 EST
Created attachment 289111 [details]
kernel trace

Hi Daniel,

I've got a bit more info, reconnecting the vnc viewer gives some trace
information.
Comment 8 Daniel Berrange 2007-12-14 09:47:00 EST
Unless you can reproduce the problems with a 64-bit guest, we're not going to
spend any time on this ticket. 32-on-64 is known to randomly, non-reproducably
crash - it is simply not possible to debug it. We've wasted weeks attempting to
do so in the past.
Comment 9 Bill Burns 2007-12-14 11:35:48 EST
Ihis is a dpulicate of 250427. This has been fixed in the RHEL 5.2 stream.
If there is a separate Anaconda issue please file a separate BZ. Also if this
happens on non-PV guests, please reopen.

*** This bug has been marked as a duplicate of 250427 ***
Comment 10 Andreas Thienemann 2007-12-16 19:38:48 EST
As discussed in private mail, installing 2.6.18-59.el5bbHPmgmtxen as the Dom0
kernel fixes this issue.

Note You need to log in before you can comment on or make changes to this bug.