Bug 250427 - kernel panic when installing 32-bit guest on 64-bit host
Summary: kernel panic when installing 32-bit guest on 64-bit host
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen (Show other bugs)
(Show other bugs)
Version: 5.1
Hardware: All Linux
high
high
Target Milestone: ---
: ---
Assignee: Bill Burns
QA Contact: Martin Jenner
URL:
Whiteboard:
Keywords:
: 424421 443753 444729 (view as bug list)
Depends On: 318891
Blocks: 222082 RHEL5u2_relnotes
TreeView+ depends on / blocked
 
Reported: 2007-08-01 15:44 UTC by Daniel Berrange
Modified: 2018-10-19 22:03 UTC (History)
10 users (show)

Fixed In Version: RHBA-2008-0314
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 14:47:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Guest log from 2.6.18-36.el5xen (11.93 KB, text/plain)
2007-08-01 15:45 UTC, Daniel Berrange
no flags Details
Guest log from the 2.6.18-8.el5xen kernel crash (6.06 KB, text/plain)
2007-08-02 13:38 UTC, Daniel Berrange
no flags Details
Logs from the hypervisor at time guest runs (89.04 KB, text/plain)
2007-08-02 14:36 UTC, Daniel Berrange
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2008:0314 normal SHIPPED_LIVE Updated kernel packages for Red Hat Enterprise Linux 5.2 2008-05-20 18:43:34 UTC

Description Daniel Berrange 2007-08-01 15:44:04 UTC
Description of problem:
Attempting to install latest RHEL-5.1 beta i686 guest on a 5.1 beta x86_64 host,
the guest kernel panics very shortly into the package installation process of
anaconda.

Version-Release number of selected component (if applicable):
2.6.18-36.el5xen.x86_64  on host
2.6.18-36.el5xen.i686  on guest

How reproducible:
Always

Steps to Reproduce:
1.virt-install  --paravirt --file /var/lib/xen/images/rhel5pvi386.img
--file-size 4 -l http://qafiler.boston.redhat.com/redhat/rhel5-server-i386/
--vnc --name rhel5pvi386 --ram 500
2. Go through anaconda and start package install
3. Wait a short while
  
Actual results:
guest crashes with kenrel panic

Expected results:
Install completes

Additional info:

Comment 1 Daniel Berrange 2007-08-01 15:45:43 UTC
Created attachment 160422 [details]
Guest log from 2.6.18-36.el5xen

Comment 2 Daniel Berrange 2007-08-01 18:39:06 UTC
I just tested using a 32-bit RHEL-5 GA install image instead of the 5.1 Beta.
This successfully installed, so even though we don't yet officially support
32-on-64, there is potentially a regression in the 5.1 kernel here.


Comment 3 RHEL Product and Program Management 2007-08-01 18:39:36 UTC
This bugzilla has Keywords: Regression.  

Since no regressions are allowed between releases, 
it is also being proposed as a blocker for this release.  

Please resolve ASAP.

Comment 4 Glauber Costa 2007-08-02 12:27:01 UTC
Dan,

I do can reproduce this bug, but with the RHEL5 kernel (2.6.18-32) the problem
persists. I recall doing one installation in which another stack trace is given.
So maybe the problem is intermittent, but was always there, and is not a
regression. Would you please try installing the 5.0 GA some more times ? 

Comment 5 Daniel Berrange 2007-08-02 13:37:08 UTC
Looks like i spoke too soon wrt to comment #2.  I can now get RHEL-5  GA to
crash too, albeit with a different stack trace

The 2.6.18-8.el5xen kernel  dies with

Call Trace:
[<c0451b60>] __handle_mm_fault+0x275/0x1070
[<c04b0689>] inode_has_perm+0x54/0x5c
[<c04d79a1>] copy_to_user+0x31/0x48
[<c04d4c17>] prio_tree_insert+0x12c/0x1f2
[<c05f63b8>] do_page_fault+0x6e8/0xbeb
[<c0455954>] do_mmap_pgoff+0x547/0x697
[<c043dc4a>] audit_syscall_exit+0x285/0x2a1
[<c05f5cd0>] do_page_fault+0x0/0xbeb
[<c0404e83>] error_code+0x2b/0x30

While the newest 5.1 beta kernel 2.6.18-36.el5xen dies

Call Trace:
[<c041b7bb>] copy_process+0xb37/0x1167
[<c041be2c>] do_fork+0x41/0x130
[<c0425182>] sigprocmask+0xcc/0xd2
[<c04031c1>] sys_clone+0x28/0x2d
[<c040534f>] syscall_call+0x7/0xb


Comment 6 Daniel Berrange 2007-08-02 13:38:54 UTC
Created attachment 160523 [details]
Guest log from the 2.6.18-8.el5xen kernel crash

Comment 7 Daniel Berrange 2007-08-02 14:36:08 UTC
Created attachment 160524 [details]
Logs from the hypervisor at time guest runs

I get this at exactly the time the guest crashes

(XEN) mm.c:1904:d1 Dom 1 cannot set foreign dom
(XEN) mm.c:1904:d1 Dom 1 cannot set foreign dom
(XEN) mm.c:1904:d1 Dom 1 cannot set foreign dom
(XEN) mm.c:1904:d1 Dom 1 cannot set foreign dom
(XEN) mm.c:1904:d1 Dom 1 cannot set foreign dom
(XEN) mm.c:1904:d1 Dom 1 cannot set foreign dom
(XEN) mm.c:612:d0 Non-privileged (1) attempt to map I/O space 00000000

Comment 8 Daniel Berrange 2007-08-02 15:06:15 UTC
Removing regression keyword, since I can get GA to crash in exactly same way now.

Comment 9 Daniel Berrange 2007-08-02 17:52:20 UTC
After more testing, what was once 100% reproducable is not 100% *not*
reproducable, so we have a nasty non-deterministic bug here.

Further to comment #5 which had different backtraces for -8.el5 vs -36.el5, I
have now also seen both stack traces with both kernels so its unlikely to be any
difference there.


Comment 20 Bill Burns 2007-12-07 19:35:24 UTC
Fixed by bz 318891.


Comment 21 Bill Burns 2007-12-14 16:35:49 UTC
*** Bug 424421 has been marked as a duplicate of this bug. ***

Comment 22 Don Zickus 2008-01-24 16:34:19 UTC
You can download this test kernel from http://people.redhat.com/dzickus/el5

Comment 25 Don Domingo 2008-03-12 23:34:02 UTC
quick FYI: RHEL5.2 release notes contains the following (as per BZ#s 425411 and
383211):

<quote>
(x86_64) You can now run paravirtualized 32-bit guests on 64-bit hosts. This
capability is now included as a technology preview. Note that the ability to
save, restore, and migrate paravirtualized 32-bit guests on 64-bit hosts is not
functional, and as such should not be attempted.
</quote>

please advise if any further revisions are required. thanks!

Comment 26 Don Domingo 2008-04-02 02:09:55 UTC
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Comment 27 Chris Lalancette 2008-04-23 13:40:50 UTC
*** Bug 443753 has been marked as a duplicate of this bug. ***

Comment 28 Daniel Berrange 2008-04-30 11:50:50 UTC
*** Bug 444729 has been marked as a duplicate of this bug. ***

Comment 30 errata-xmlrpc 2008-05-21 14:47:55 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2008-0314.html



Note You need to log in before you can comment on or make changes to this bug.