Bug 424821 - Update request: ocaml-lablgtk 2.10.0
Update request: ocaml-lablgtk 2.10.0
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: ocaml-lablgtk (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Gérard Milmeister
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-14 05:16 EST by Stijn Hoop
Modified: 2008-02-21 09:19 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-21 09:07:35 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Stijn Hoop 2007-12-14 05:16:34 EST
Version 2.10.0 of ocaml-lablgtk is out:

http://wwwfun.kurims.kyoto-u.ac.jp/soft/olabl/lablgtk.html

I needed it to package some software for local use, so here are the links to the
updated .spec files. I do not use this software myself, and I do not have the
time to track upstream so I cannot become a real maintainer of this package. I
simply wished to share my work for others to build on.

The .spec file is based on the one for the current ocaml-lablgtk version in
Fedora 8, 2.6.0. There is one patch file included, taken from the ATrpms
repository which includes the correct version; but AT's spec file produces a lot
more rpmlint warnings than this one.

Spec URL: http://sandcat.nl/~stijn/RPM/ocaml-lablgtk.spec
SRPM URL: http://sandcat.nl/~stijn/RPM/ocaml-lablgtk-2.10.0-1.fc8.src.rpm

Note that I do not know if this is binary compatible with version 2.6.0 because
we do not use other software that uses this library. The
requires/obsolets/provides may have to be adjusted in case the new version is
not binary compatible.
Comment 1 Richard W.M. Jones 2008-02-16 14:37:46 EST
Lablgtk 2.10.0 has been in Rawhide for a few months.  Can you use that
version?

If we pull lablgtk 2.10.0 into F8 then there are a number of dependent
packages which need to be rebuilt.  At least these ones:
 - ocaml-libvirt
 - freetennis
 - ocaml-camlimages
 - ocaml-ocamlnet
(and maybe others that depend on those - I didn't check).
Comment 2 Richard W.M. Jones 2008-02-21 09:07:35 EST
Closed - this is in Rawhide now.
Comment 3 Stijn Hoop 2008-02-21 09:19:55 EST
Sorry for not responding earlier. The current situation will work for us -- I
can keep my own version locally until we switch to F9.

Thanks!

Note You need to log in before you can comment on or make changes to this bug.