Bug 42490 - man latin1 fails
Summary: man latin1 fails
Status: CLOSED DUPLICATE of bug 19555
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: groff (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: noarch Linux
medium
medium
Target Milestone: ---
Assignee: Trond Eivind Glomsrxd
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-05-27 19:40 UTC by Need Real Name
Modified: 2007-04-18 16:33 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-27 19:40:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-05-27 19:40:04 UTC
Description of Problem:
The latin1 and latin2 man pages fail

How Reproducible:
man latin1

Steps to Reproduce:
1. man latin1
2. man latin2
3. 

Actual Results:
"realpath on `man7/iso_8859-1.7' failed: No such file or directory"


Expected Results:
a latin1 man page

Additional Information:

There's a typo in the latin1 and latin2 man pages which causes man to
fail with the error "realpath on `man7/iso_8859-1.7' failed: No such
file or directory".  This patch corrects the problem.  The man pages
should be uncompressed first.  They're so small that it really makes
no sense to recompress them.

man7$> pwd
/usr/share/man/man7

man7$> diff -u latin1.7{~,}
--- latin1.7~  Sat Nov 27 10:42:36 1999
+++ latin1.7   Sat May 26 18:18:11 2001
@@ -1 +1 @@
-.so man7/iso_8859_1.7
+.so man7/iso_8859-1.7

man7$> diff -u latin2.7{~,}
--- latin2.7~  Sat Nov 13 06:45:51 1999
+++ latin2.7   Sat May 26 18:18:29 2001
@@ -1 +1 @@
-.so man7/iso_8859_2.7
+.so man7/iso_8859-2.7

Comment 1 Trond Eivind Glomsrxd 2001-05-29 16:27:58 UTC
No typo... latin2 contains iso_8859_2.7, which contains iso_8859-2.7, which is
the file you're looking for. This is a groff bug.

*** This bug has been marked as a duplicate of 19555 ***


Note You need to log in before you can comment on or make changes to this bug.