Bug 425790 - Add support to E7221 graphics controller
Add support to E7221 graphics controller
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
: Patch, Reopened
Depends On:
Blocks: 425788
  Show dependency treegraph
 
Reported: 2007-12-15 13:12 EST by Carlos Martín
Modified: 2008-04-01 22:15 EDT (History)
1 user (show)

See Also:
Fixed In Version: 7.0.2-3.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-13 00:08:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Spec (29.64 KB, text/x-rpm-spec)
2007-12-15 13:13 EST, Carlos Martín
no flags Details
Spec (29.73 KB, text/x-rpm-spec)
2007-12-15 13:14 EST, Carlos Martín
no flags Details
e7221 support (4.27 KB, patch)
2007-12-15 13:15 EST, Carlos Martín
no flags Details | Diff

  None (edit)
Description Carlos Martín 2007-12-15 13:12:18 EST
Description of problem:
E7221 isn't supported by mesa i915 driver.

Version-Release number of selected component (if applicable):
All
Comment 1 Carlos Martín 2007-12-15 13:13:40 EST
Created attachment 289698 [details]
Spec
Comment 2 Carlos Martín 2007-12-15 13:14:31 EST
Created attachment 289699 [details]
Spec
Comment 3 Carlos Martín 2007-12-15 13:15:09 EST
Created attachment 289700 [details]
e7221 support
Comment 4 Carlos Martín 2007-12-15 13:17:03 EST
This patches fixes the problem. Currently works for me on s Supermicro P8SCT
motherboard.
Comment 5 Adam Jackson 2008-01-22 13:38:08 EST
Fixed in rawhide.  Currently building mesa-7.0.2-3.fc8 for updates.
Comment 6 Carlos Martín 2008-01-23 18:17:16 EST
Thanks, I will test an soon as it's in updates-testing :). Just waiting for bug
425786 to get AGPGART support for E7221 chipset... 
Comment 7 Matěj Cepl 2008-01-24 12:14:49 EST
OK, so I will put NEEDINFO on you, so that we don't loose this bug.
Comment 8 Fedora Update System 2008-01-24 17:01:47 EST
mesa-7.0.2-3.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update mesa'
Comment 9 Carlos Martín 2008-01-25 10:06:43 EST
I've already test the new mesa packages and works as expected. Keep in mind that
it only works with new intel driver. (Old i810 driver fails) 
Comment 10 Matěj Cepl 2008-01-28 09:55:31 EST
I am afraid there is not much development in i810 driver at all these days.
Comment 11 Carlos Martín 2008-01-29 10:29:52 EST
Yes, I think so, but without AGPGART support for E7221 in the kernel, i810
driver is the ONLY driver usable yet. Adam, please, review 425786 bug, patches
provided in it also fits in rawhide kernels (except not tested intelfb one, wich
isn't really required for X)
Comment 12 Matěj Cepl 2008-01-29 12:39:27 EST
OK, reopening.
Comment 13 Fedora Update System 2008-02-13 00:08:27 EST
mesa-7.0.2-3.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Don Domingo 2008-04-01 22:15:27 EDT
Hi,
the RHEL5.2 release notes will be dropped to translation on April 15, 2008, at
which point no further additions or revisions will be entertained.

a mockup of the RHEL5.2 release notes can be viewed at the following link:
http://intranet.corp.redhat.com/ic/intranet/RHEL5u2relnotesmockup.html

please use the aforementioned link to verify if your bugzilla is already in the
release notes (if it needs to be). each item in the release notes contains a
link to its original bug; as such, you can search through the release notes by
bug number.

Cheers,
Don

Note You need to log in before you can comment on or make changes to this bug.