Bug 425829 - python-nevow build requires not yet available twisted packages
python-nevow build requires not yet available twisted packages
Status: CLOSED NEXTRELEASE
Product: Fedora EPEL
Classification: Fedora
Component: python-nevow (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
: Reopened
: 463026 (view as bug list)
Depends On:
Blocks: EPEL5-BrokenDeps
  Show dependency treegraph
 
Reported: 2007-12-16 05:38 EST by Thorsten Leemhuis
Modified: 2009-01-02 09:45 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.9.32-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2009-01-02 09:45:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thorsten Leemhuis 2007-12-16 05:38:18 EST
Description of problem:
package: python-Coherence - 0.2.1-3.el5.noarch from epel5-testing
  unresolved deps: 
     python-twisted-core
     python-nevow
     python-twisted-web

Additional info:
I'd like to see the above problems solved.

thomasvs, would you be willing to take care of python-twisted-core and
python-twisted-web in EPEL5?

thias, would you be willing to take care of python-nevow in EPEL5?
Comment 1 Matthias Saou 2007-12-17 15:56:02 EST
I've just updated python-nevow to 0.9.26 on Fedora devel, and on EL-4 and EL-5
at the same time (branches were already created a long time ago). I'll rebuild
and test those EL packages now.
Comment 2 Matthias Saou 2008-02-03 06:08:17 EST
I'm really sorry for apparently never finishing the testing I mentioned...
I've updated Rawhide and F-8 to the latest 0.9.29 now, and I'll rebuild on the
EL branches directly, as the packages will go into "testing" anyway, and
shouldn't break anything existing even if they have problems.

For twisted, the best (if not already done) would be to open a different bug report.
Comment 3 Matthias Saou 2008-02-03 09:03:29 EST
Reopening against python-nevow, since it build requires the twisted packages,
thus can't be rebuilt in EPEL at all.

Thomas : Will you rebuild twisted in EPEL, or are you okay with someone else
doing it?
Comment 4 Matthias Saou 2009-01-02 08:47:03 EST
*** Bug 463026 has been marked as a duplicate of this bug. ***
Comment 5 Matthias Saou 2009-01-02 09:45:11 EST
So, Twisted has appeared in EPEL5 in the meantime, but python-twisted-web was too old to work with python-nevow (it was 0.6.0). I've carefully reviewed the changes in python-twisted-web 0.7.0 and updated the EPEL5 to that version, which now allows to build and use python-nevow at last. The update shouldn't break anything, and that version has been in use in Fedora for a long time now, but you never know.

I've rebuilt python-nevow at last, so closing.

Note You need to log in before you can comment on or make changes to this bug.