Bug 426024 - nx uses obsolete (and non-POSIX) sa_restorer
nx uses obsolete (and non-POSIX) sa_restorer
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: nx (Show other bugs)
8
alpha Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 15:35 EST by Oliver Falk
Modified: 2008-03-10 06:23 EDT (History)
1 user (show)

See Also:
Fixed In Version: 3.1.0-25.1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-06 11:34:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Oliver Falk 2007-12-17 15:35:17 EST
I cloned this bug from libwvstreams, as it's quite the same.
Please find a build.log from nx here:

http://buildsys.zero42.at/koji/getfile?taskID=82832&name=build.log

Some relevant comments from my libwvstreams bug:

+++ This bug was initially created as a clone of Bug #402531 +++

From my build.log:
[oliver@gosa libwvstreams]$ cat .build-4.4-1.fc8.log |tail
utils/wvcrash.cc:96: warning: ignoring return value of 'ssize_t write(int, const
void*, size_t)', declared with attribute warn_unused_result
utils/wvcrash.cc: In function 'void wvcrash_add_signal(int)':
utils/wvcrash.cc:388: error: 'struct sigaction' has no member named 'sa_restorer'
make[1]: *** [utils/wvcrash.o] Error 1
make[1]: Leaving directory `/home/oliver/cvs/F-8/libwvstreams/wvstreams-4.4'
error: Bad exit status from /var/tmp/rpm-tmp.99427 (%build)


RPM build errors:
    Bad exit status from /var/tmp/rpm-tmp.99427 (%build)


From sigaction manpage:
<snip>
  The sa_restorer element is obsolete and should not be used.  POSIX does not
specify
  a sa_restorer element.
</snip>
Comment 1 Axel Thimm 2007-12-28 18:28:48 EST
Thanks for the report. I have two questions:

o what is the suggested action wrt to the missing sa_restorer filed?
o I just tried a build on F9 - while it failed at the very end when computing the
  dependencies for other reasons, it did manage to build everything. How could
  that be, shouldn't F9 choke on this as well?
Comment 2 Fedora Update System 2008-03-04 18:03:11 EST
nx-3.1.0-25.1.fc8 has been submitted as an update for Fedora 8
Comment 3 Oliver Falk 2008-03-06 05:53:13 EST
http://buildsys.zero42.at/koji/getfile?taskID=91317&name=build.log

still fails.

sa_restorer seems to be still available in x86 and others, while alpha is more
strict and it is disabled...

The best thing is to just delete the sa_restorer lines!
Comment 4 Fedora Update System 2008-03-06 11:34:19 EST
nx-3.1.0-25.1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 5 Axel Thimm 2008-03-06 12:21:07 EST
I don't feel quite that confident on removing sa_restorer in x86 w/o
investigating and understanding what impact it may have. Maybe the best thing is
to have a conditional patch on whether sa_restorer exists in the source or
failing that a specfile conditional for alpha that patches it out?

Accepting both kind of patches :)
Comment 6 Oliver Falk 2008-03-10 06:23:43 EDT
Anything I find on sa_restorer is, that it was dangerous, that it should not be
used (anymore) and that code should be removed... Well, I'm not an expert, but
for me this sounds like: Simply don't set sa_restorer and everything should be fine.

Note You need to log in before you can comment on or make changes to this bug.