Bug 426127 - system-config-kickstart fails when used with non-fedora yum configuration
system-config-kickstart fails when used with non-fedora yum configuration
Status: CLOSED DUPLICATE of bug 337161
Product: Fedora
Classification: Fedora
Component: system-config-kickstart (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Lumens
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-18 13:15 EST by Laurie Reeves
Modified: 2007-12-18 13:25 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 13:25:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to fix problem (806 bytes, patch)
2007-12-18 13:15 EST, Laurie Reeves
no flags Details | Diff

  None (edit)
Description Laurie Reeves 2007-12-18 13:15:30 EST
Description of problem:
system-config-kickstart fails when used with non-fedora yum configuration.

Version-Release number of selected component (if applicable):
2.7.12-1.fc8

How reproducible:
Always.

Steps to Reproduce:
1. Remove all Fedora yum configuration
2. run system-config-kickstart
  
Actual results:
Loading "priorities" plugin
0 packages excluded due to repository priority protections
Component: system-config-kickstart
Summary: TB2b74954f packages.py:143:__init__:AttributeError: 'module' object has
no attribute 'Error'

Traceback (most recent call last):
  File "/usr/bin/system-config-kickstart", line 83, in <module>
    kickstartGui.kickstartGui(file)
  File "/usr/share/system-config-kickstart/kickstartGui.py", line 167, in __init__
    self.packages_class = packages.Packages(xml, self.ksHandler)
  File "/usr/share/system-config-kickstart/packages.py", line 181, in __init__
    self.y = sckYumBase(pbar)
  File "/usr/share/system-config-kickstart/packages.py", line 143, in __init__
    except yum.Error.RepoError:
AttributeError: 'module' object has no attribute 'Error'

Local variables in innermost frame:
repo: development
tempfile: <module 'tempfile' from '/usr/lib/python2.5/tempfile.pyc'>
self: <packages.sckYumBase object at 0xa88496c>
repoorder: ['development', 'fedora']
callback: <pirut.Progress.PirutProgressCallback instance at 0xa88472c>


Expected results:
Workingness.

Additional info:
Patch included.
Comment 1 Laurie Reeves 2007-12-18 13:15:30 EST
Created attachment 289910 [details]
Patch to fix problem
Comment 2 Chris Lumens 2007-12-18 13:25:09 EST

*** This bug has been marked as a duplicate of 337161 ***

Note You need to log in before you can comment on or make changes to this bug.