Bug 426186 - MadWifi doesn't work with AR5418 on Fedora kernel
MadWifi doesn't work with AR5418 on Fedora kernel
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-12-18 21:46 EST by Jeff Cook
Modified: 2007-12-21 11:27 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-12-19 09:45:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Jeff Cook 2007-12-18 21:46:46 EST
Atheros AR5418 wireless devices, such as those included in the MacBook Pro Core
2 Duo, will scan and detect networks but will not join them via DHCP with either
MadWifi SVN or stable

This is related to http://madwifi.org/ticket/1543 and possibly
https://bugzilla.redhat.com/show_bug.cgi?id=374881 . Sure enough, SVN > 2712
functions as expected on Ubuntu, as reported. It appears that some kernel tweak
is required to make MadWifi functional on Fedora 8 for that chipset. This wasn't
working a week ago; I don't know if there's been a kernel update correcting the
issue since then and I don't know what version of the kernel package I was using
when I encountered this problem.

Fedora's bundled ath5k doesn't function with AR5418 yet.
Comment 1 John W. Linville 2007-12-19 09:45:41 EST
Sorry, can't support madwifi in Fedora...
Comment 2 Jeff Cook 2007-12-19 10:17:59 EST
It's really not being able to support MadWifi? Wouldn't this kind of issue
expose something a little deeper that may impair other projects? No one's asking
you to distribute MadWifi, but fixing a kernel build error manifested in an
incompatibly licensed program surely doesn't amount to supporting or endorsing
the thing, right?

I hate to patronize, but that response seems like a copout to me. I really do
what I can to love Fedora, it has a lot of appeal to me ... but if this is how
Red Hat chooses to conduct business, I won't bother with it anymore and I feel
that that'd be a shame.
Comment 3 John W. Linville 2007-12-19 15:29:01 EST
I'm not really sure what you expect me to do.  Perhaps if you could point to a 
specific problem (or a specific patch that fixed a non-descript problem) we 
could evaluate it -- of course if there was a specific problem with the kernel 
it should be handled upstream anyway.  That way it would filter down to 
Fedora, Ubuntu, and all the other distros.  But, I digress...

All I see is that there was a lot of talk about which SVN version of madwifi 
worked or didn't, then someone updated their Ubuntu kernel and things 
magically worked.  It also seemed that the older madwifi versions were working 
with the older Ubuntu kernel, so that doesn't really identify which one really 
had a problem.

Anyway, we do our best to support ath5k here.  I hope their reverse 
engineering folks (also part of the overal madwifi team BTW) get to your 
device soon -- really, I do.  In the meantime, I just don't have the bandwidth 
to chase down problems in madwifi.  I'm sorry.
Comment 4 Jeff Cook 2007-12-21 11:27:52 EST
No problem. Thank you for the prompt and polite response. I'll see if I can find
something more specific. : )

Note You need to log in before you can comment on or make changes to this bug.