Bug 426275 - move SDL_AUDIODRIVER=esd wrapper script to SDL itself
move SDL_AUDIODRIVER=esd wrapper script to SDL itself
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: SDL (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Thomas Woerner
Fedora Extras Quality Assurance
:
: 426764 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-19 13:44 EST by Need Real Name
Modified: 2008-01-07 13:28 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-07 13:28:25 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2007-12-19 13:44:59 EST
Description of problem:
Running quake3 in Fedora8 under PulseAudio has no sound.

Running the game itself works fine with the absence of sound, however, the game
then freezes the display on the quake screen when you try to quit.
If you kill quake from another terminal, you still end up with a frozen mouse
and an X-display stuck in a low resolution state.

THIS IS BAD AND DANGEROUS.

Fix is simple, set the environment variable SDL_AUDIODRIVER="esd".

I would suggest that the maintainers write a little 1-line wrapper for quake3
that says:

SDL_AUDIODRIVER="esd" /usr/bin/quake3.orig
Comment 1 Hans de Goede 2007-12-19 14:34:03 EST
Thanks for reporting!

However this is not a quake3 bug, but rather an SDL bug, changing component.

2 those just tuning in:

There was a discussion on the mailinglist about the fact that the
SDL_AUDIODRIVER=esd wrapper script should be in SDL itself rather then in
SDL_mixer, I seem to remember that Warren (hence I added you to the CC),
responded that there were no SDL using apps which did not also use SDL_mixer for
sound.

As you can read above in the original bug report however, there are applications
which do use SDL for audio without using SDL_mixer, so can the wrapper script
please be moved to SDL proper?

Comment 2 Need Real Name 2007-12-19 19:37:55 EST
gnuboy (which is also a Fedora rpm) has an sdl version called sdlgnuboy that
also uses SLD for audio and thus screws up the mouse and screen without the
above wrapper.

Now I still can't get sdlgnuboy or xgnboy to work (I reported that as another
bugzilla bug) but at least sdlgnuboy no longer crashes my display.
Comment 3 Warren Togami 2007-12-19 20:50:40 EST
I'll do this tomorrow.
Comment 4 Warren Togami 2007-12-20 00:48:46 EST
https://admin.fedoraproject.org/updates/F8/pending/SDL_mixer-1.2.8-6.fc8,SDL-1.2.12-4.fc8
Please test this and report there.
Comment 5 Hans de Goede 2007-12-20 06:04:25 EST
Tested both with pulseaudio and without pulseaudio (and alsa-plugins-pulseaudio).

Both work as they should. I've also added this as a comment to the update.
Comment 6 Fedora Update System 2007-12-21 16:11:19 EST
SDL_mixer-1.2.8-6.fc8, SDL-1.2.12-4.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Per Inge Mathisen 2007-12-21 18:43:39 EST
This update has totally broken SDL-devel. The reason is that
/usr/include/SDL/SDL_config.h now contains shell code. Please fix urgently.

To reproduce, great hello world that has #include <SDL.h>, and try to compile.
Comment 8 Warren Togami 2007-12-21 22:44:27 EST
http://koji.fedoraproject.org/packages/SDL/1.2.12/5.fc8/
Please test this new build and report back.
Comment 9 Per Inge Mathisen 2007-12-22 08:02:06 EST
The new build (1.2.12-5.fc8) works here.
Comment 10 Hans de Goede 2007-12-31 09:13:23 EST
*** Bug 426764 has been marked as a duplicate of this bug. ***
Comment 11 Hans de Goede 2008-01-07 13:28:25 EST
Closing, as the fix for this has been in updates for a while now.

Note You need to log in before you can comment on or make changes to this bug.