Bug 42656 - a2ps doesn't print plain text files
a2ps doesn't print plain text files
Status: CLOSED DUPLICATE of bug 40532
Product: Red Hat Linux
Classification: Retired
Component: a2ps (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Depends On:
  Show dependency treegraph
Reported: 2001-05-29 03:09 EDT by Tomasz Kepczynski
Modified: 2008-05-01 11:38 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2002-01-09 10:17:16 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
Analysis and proposed patch (1.30 KB, patch)
2001-05-29 05:47 EDT, Need Real Name
no flags Details | Diff
Corrected patch for this bug and bug #40532 (1.52 KB, patch)
2001-05-29 07:01 EDT, Need Real Name
no flags Details | Diff

  None (edit)
Description Tomasz Kepczynski 2001-05-29 03:09:39 EDT
From Bugzilla Helper:
User-Agent: Mozilla/4.77 [en] (X11; U; Linux 2.4.2-2 i686)

Description of problem:
a2ps used to convert text files to postscript before sending them to
printer. At the moment it seems that the conversion fails as the postscript
printer (HPLJ 4050N) doesn't print. In addition if printing to postscript
file and viewing it with gv - ghostscript fails with errors or gv displays
empty page only with frame around it.
I don't know what magic a2ps uses to convert text to postscript so it
may be possible that actual fault is in some other place.
This used to work in RH 7.0 & 6.2.

How reproducible:

Steps to Reproduce:
1. print any text file with a2ps

Additional info:

I use Polish ("pl_PL") locale and latin2 encoding but the latter doesn't
seem to matter. The fault disappers when locale is set to "en_GB" or "C".
If locale is set to "en" a2ps dumps core.
Comment 1 Need Real Name 2001-05-29 05:47:18 EDT
Created attachment 19855 [details]
Analysis and proposed patch
Comment 2 Need Real Name 2001-05-29 07:01:06 EDT
Created attachment 19863 [details]
Corrected patch for this bug and bug #40532
Comment 3 Tim Waugh 2002-01-10 04:37:11 EST

*** This bug has been marked as a duplicate of 40532 ***

Note You need to log in before you can comment on or make changes to this bug.