Bug 426574 - appletouch does not recognize trackpad in macbook 3.1
appletouch does not recognize trackpad in macbook 3.1
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 07:26 EST by Chris Nolan
Modified: 2008-03-27 06:58 EDT (History)
1 user (show)

See Also:
Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 06:58:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test kernel patch for 2.6.23 x86_64 (105.60 KB, patch)
2007-12-22 12:46 EST, Chris Nolan
no flags Details | Diff
Updated Test kernel patch for 2.6.23 x86_64 (9.49 KB, patch)
2008-01-19 05:42 EST, Chris Nolan
no flags Details | Diff
Updated kernel patch for 2.6.23 x86_64 (1.54 KB, patch)
2008-01-20 11:42 EST, Chris Nolan
no flags Details | Diff
Updated kernel patch for 2.6.23 x86_64 (1.32 KB, patch)
2008-02-12 07:55 EST, Chris Nolan
no flags Details | Diff

  None (edit)
Description Chris Nolan 2007-12-22 07:26:02 EST
Description of problem:

appletouch does not recognize trackpad in macbook 3.1

the macbook 3.1 ("Santa Rosa") has a trackpad that appears to be identical to
previous generations, but with new IDs.

How reproducible:

Very - every time.

Steps to Reproduce:
1. Install FC8 x86_64
2. Update everything
3. Load the appletouch kernel module
4. Use synaptic driver in xorg.conf for the touchpad input device
5. Restart X
  
Actual results:

X fails to start as it cannot find a synaptics device

Expected results:

Touchpad should be found as a synaptics controllable device, synaptics driver
should load and X should start as normal

Additional info:

Patch available for Ubuntu kerbel at
https://bugs.edge.launchpad.net/ubuntu/+source/linux-meta/+bug/162090
Comment 1 Chris Nolan 2007-12-22 12:46:48 EST
Created attachment 290293 [details]
Test kernel patch for 2.6.23 x86_64

This is a kernel patch to fix both this bug (426574) and 426576 - the
appletouch.c part of this patch is relevant to this bug. It seems to work for
me, but needs testing. 

Based on patch from ubuntu at
https://bugs.edge.launchpad.net/ubuntu/+source/linux-meta/+bug/162090
Comment 2 Chuck Ebbert 2008-01-02 14:52:20 EST
Your patch needs to be regenerated because it includes the .orig files in their
entirety as new files.
Comment 3 Chris Nolan 2008-01-05 09:34:29 EST
(In reply to comment #2)
> Your patch needs to be regenerated because it includes the .orig files in their
> entirety as new files.

I'm new to all this and I followed the instructions here
(http://fedoraproject.org/wiki/Docs/CustomKernel#head-3e01c3430de111cd9ac1cf65266d44ae7e3f4fac)
to create the patch. Can you suggest a different diff command that would
generate the correct format of patch?
Comment 4 Chuck Ebbert 2008-01-08 13:30:47 EST
(In reply to comment #3)
> (In reply to comment #2)
> > Your patch needs to be regenerated because it includes the .orig files in their
> > entirety as new files.
> 
> I'm new to all this and I followed the instructions here
>
(http://fedoraproject.org/wiki/Docs/CustomKernel#head-3e01c3430de111cd9ac1cf65266d44ae7e3f4fac)
> to create the patch. Can you suggest a different diff command that would
> generate the correct format of patch?

You just need to remove the .orig files so the source tree is clean before
generating the patch.

Comment 5 Johan Kok 2008-01-19 03:45:27 EST
*** Bug 426576 has been marked as a duplicate of this bug. ***
Comment 6 Chris Nolan 2008-01-19 04:37:45 EST
I am trying to help here but I am still completely at a loss as to how to
generate the patch file without it containing the .orig files in their entirety.
I find it odd that the fedora project wiki doesn't give the correct instructions
for what to do here.

I have two hardlinked directories in BUILD/ that I am using to build the patch:

kernel-2.6.23.orig
kernel-2.6.23.new

The edited files are in .new

I then ran this diff command to create the patch:

diff -uNrp kernel-2.6.x.orig kernel-2.6.x.new >
../SOURCES/linux-2.6-my-new-patch.patch

All this is exactly how the fedoraproject wiki explains to do it. 

Comment #4 above doesn't make much sense to me. Remove which ".orig" files?
Comment 7 Chris Nolan 2008-01-19 05:42:18 EST
Created attachment 292253 [details]
Updated Test kernel patch for 2.6.23 x86_64

This is an updated kernel patch to fix both this bug (426574) and 426576 - the
appletouch.c part of this patch is relevant to this bug. 

I have been running this patched kernel for 4 weeks now without any problems
whatsoever. Using this patched kernel the touchpad works perfectly with the
synaptics drivers and the function key works as desired. (This is tested on a
macbook 3,1 santa rosa.)
Comment 8 Chris Nolan 2008-01-19 05:47:06 EST
Please ignore Comment #6 - I figured out what was meant by "remove the .orig
files" - must have been having a dim moment. 

The patch attached above in Comment #7 is the recreated patch which does not
include the .orig files in their entirety.
Comment 9 Chris Nolan 2008-01-20 11:42:43 EST
Created attachment 292294 [details]
Updated kernel patch for 2.6.23 x86_64

This is an updated kernel patch containing proposed kernel fixes for this bug
only.

I have yet to test this individual patch but I will update this report once I
have done so. We could really use some more people with the macbook 3,1 to test

this also.
Comment 10 Chuck Ebbert 2008-01-23 19:32:42 EST
Patch in 2.6.23.14-119. (Taken from the Mactel site.)
Comment 11 Chris Nolan 2008-01-30 06:55:16 EST
That is great news. Any chance of getting the patch from bug #426576 included
soon too?
Comment 12 Fedora Update System 2008-02-10 22:34:04 EST
kernel-2.6.23.15-137.fc8 has been submitted as an update for Fedora 8
Comment 13 Fedora Update System 2008-02-11 17:38:50 EST
kernel-2.6.23.15-137.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 Chris Nolan 2008-02-12 04:38:56 EST
kernel-2.6.23.15-137.fc8 does not fix this bug - using that kernel, the trackpad
on macbook 3,1 is not recognised by appletouch and cannot be configured using
the synaptics driver in Xorg.
Comment 15 Chris Nolan 2008-02-12 07:35:12 EST
I have tested the new kernel some more, and found the following:

1) The stock kernel 2.6.23.15-137.fc8 from the f8 updates repository does not
fix this bug. The error is the same as in the first post of this bug report.

2) Building the stock kernel 2.6.23.15-137.fc8 from source does not fix this bug
despite their being a patch included that is supposed to fix it.

3) Building the kernel 2.6.23.15-137.fc8 from source and patching with the
latest patch from bug #426576 does fix this bug and also fixes bug #426576

Thus it seems that the patch submitted for this bug does not work correctly
without the patch for bug #426576 also being applied. I can't see why this would
be the case (as the patches seem distinct from one another), but it appears to
be so.
Comment 16 Chris Nolan 2008-02-12 07:55:41 EST
Created attachment 294653 [details]
Updated kernel patch for 2.6.23 x86_64

Just a cleaner version of the same patch (corrected the file paths). Tested and
works with 2.6.23.15-137 but only works in combination with patch from bug
#426576.
Comment 17 Chris Nolan 2008-02-12 16:03:26 EST
I now believe the reason the patch from bug #426576 (at least the part where the
new device IDs are added) is also required is to prevent the usbhid driver from
claiming the touchpad device ahead of the appletouch driver. The patch sets a
flag called HID_QUIRK_IGNORE_MOUSE for the Macbook keyboards.

Thus, the patch for this bug is dependent on the patch from bug #426576 and so
both patches should be included in the kernel.
Comment 18 Michael Tiemann 2008-03-09 05:02:45 EDT
I would love to see this merged so I can use a standard fedora kernel.
Comment 19 ryan roth 2008-03-10 16:57:19 EDT
Ditto, I would love to be able to use a stock fedora kernel, please merge this
patch soon
Comment 20 Chris Nolan 2008-03-27 06:58:37 EDT
Bug #425576 is now fixed which in-turn fixes this bug.

kernel-2.6.24.3-50.fc8 works just fine with the macbook 3,1 touchpad and keyboard.

Note You need to log in before you can comment on or make changes to this bug.