Bug 426576 - [PATCH] macbook 3.1 and apple aluminum keyboards fn key does not work
[PATCH] macbook 3.1 and apple aluminum keyboards fn key does not work
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-22 08:57 EST by Chris Nolan
Modified: 2008-09-10 21:35 EDT (History)
3 users (show)

See Also:
Fixed In Version: 2.6.24.3-50.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-26 13:15:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Test kernel patch for 2.6.23 x86_64 (105.60 KB, patch)
2007-12-22 12:51 EST, Chris Nolan
no flags Details | Diff
Updated kernel patch for 2.6.23 x86_64 (7.94 KB, patch)
2008-01-20 11:39 EST, Chris Nolan
no flags Details | Diff
Updated kernel patch for 2.6.23 x86_64 (6.44 KB, patch)
2008-02-12 07:39 EST, Chris Nolan
no flags Details | Diff
Updated kernel patch for 2.6.24 x86_64 (8.24 KB, patch)
2008-03-14 10:51 EDT, Chris Nolan
no flags Details | Diff
Update to Apple aluminum keyboard key mappings (2.05 KB, text/plain)
2008-03-19 10:51 EDT, Chuck Ebbert
no flags Details

  None (edit)
Description Chris Nolan 2007-12-22 08:57:53 EST
Description of problem:

Macbook 3.1 and apple aluminum keyboards fn key does not work.

fn key is required on apple keyboards to do common functions (delete,
pageup/down, home/end, volume, etc). The apple aluminum keyboard and new macbook
3.1 ("Santa Rosa") are both affected.

How reproducible:

Every time.

Steps to Reproduce:
1. Install FC8 x86_64 on an Apple Macbook 3.1
  
Actual results:

The fn key doesn't work.

Expected results:

The fn key should work.

Additional info:

Bug submitted and patch created for ubuntu kernel at
https://bugs.edge.launchpad.net/ubuntu/+source/linux-meta/+bug/162083
Currently trying to use the same patch for FC8. Will report on success or otherwise.
Comment 1 Chris Nolan 2007-12-22 12:51:52 EST
Created attachment 290294 [details]
Test kernel patch for 2.6.23 x86_64

Test kernel patch for 2.6.23 x86_64

This is a kernel patch to fix both this bug (426576) and 426574 - the
appletouch.c part of this patch is not relevant to this bug but is relevant to
426574. (Maybe the bugs should be merged or maybe the patches should be split
up). It seems to work for me, but needs testing. 

Based on patch from ubuntu at
https://bugs.edge.launchpad.net/ubuntu/+source/linux-meta/+bug/162083

Note: I am not sure of the upstream status of these fixes - the ubuntu bug
tracker suggests some of the fixes may already be applied upstream in 2.6.24
Comment 2 Johan Kok 2008-01-19 03:45:26 EST
Chris, as you suggested in comment #1, I'm closing this bug as a duplicate of #426574. Keeping two bug 
reports for the same patch does not seem very useful.  

*** This bug has been marked as a duplicate of 426574 ***
Comment 3 Chris Nolan 2008-01-19 06:04:34 EST
Johan, are you sure this should be treated as the same/duplicate bug? The bugs
themselves are quite different - this one relates to the apple "fn" key while
#426574 relates to the touchpad and appletouch/synaptics. 

I am not sure, but I feel it may make more sense for me to create separate patch
files for each bug rather than combine the bugs?
Comment 4 Johan Kok 2008-01-19 09:58:52 EST
I must have missed something when looked at this report yesterday. It didn't seem reasonable to have two 
bugs with the same patch, but there are two issues here. I probably just read 'macbook', 'input device' and 
the identical patch in both reports.

Splitting this patch in two separate patches is a valid idea. Chris, can you split the proposed patch for 
these two problems and attach them to the correct bugs? 
Comment 5 Chris Nolan 2008-01-20 11:39:45 EST
Created attachment 292293 [details]
Updated kernel patch for 2.6.23 x86_64

This is an updated kernel patch containing proposed kernel fixes for this bug
only. 

I have yet to test this individual patch but I will update this report once I
have done so. We could really use some more people with the macbook 3,1 to test
this also.
Comment 6 Chris Nolan 2008-02-12 07:39:29 EST
Created attachment 294650 [details]
Updated kernel patch for 2.6.23 x86_64

Cleaner version of the same patch. Tested with 2.6.23.15-137 and works fine.
Comment 7 Christopher Brown 2008-02-12 09:03:01 EST
Chris,

Have posted this to lkml?
Comment 8 Chris Nolan 2008-02-12 09:16:21 EST
No, should I?
Comment 9 Christopher Brown 2008-02-12 09:27:16 EST
Most definitely. You'd get more review and testing of the code.
Comment 10 Chris Nolan 2008-03-07 04:09:04 EST
Can we get this patch pushed into the kernel? 

The patch for bug #426574 has been included for several releases, but that patch
is useless (it simply does not work) without this patch also being included.
Comment 11 Chuck Ebbert 2008-03-10 15:29:57 EDT
Does this patch do the same thing? It looks slightly different...

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=5906a0448208024d140e1ee0e65f9168a405fb94
Comment 12 Chris Nolan 2008-03-10 16:59:04 EDT
Yes, that patch does appear to do the same thing, but for the 2.6.25 kernel
which it seems has undergone quite a few modifications in order to support the
apple keyboards. There is another earlier patch here:

http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff_plain;h=a45d82d19a6c2a717bcc33cff243199b77fa0082

From these it appears that 2.6.25 will support this (and other) apple keyboards
by default. Looks like they added a kernel configuration option to
enable/disable support too. I wonder if they also added support for the trackpad
- I guess so (bug #426574).

If there is a Fedora 2.6.25 kernel that I can install under F8 alongside my
current kernel for testing purposes then I will give that a go and see how it works.

Meanwhile, us Macbook users would be extremely pleased if you could patch the
current 2.6.24 F8 kernel - I'd love to be able to use a stock Fedora kernel!
Comment 13 Chris Nolan 2008-03-14 10:51:22 EDT
Created attachment 298060 [details]
Updated kernel patch for 2.6.24 x86_64

This is an updated patch from the mactel-linux site for kernel 2.6.24.

I have tested this with 2.6.24.3-34 x86_64 and it works great.
Comment 14 ryan roth 2008-03-14 14:47:37 EDT
Chris will you be releasing rpms at http://www.cenolan.com/fedora8/ for 2.6.24.3-34?

I would love to not have to compile from scratch as I have been having trouble
getting them to boot on my MacBook for whatever weird reason.
Comment 15 Chris Nolan 2008-03-16 15:38:27 EDT
(In reply to comment #14)
> Chris will you be releasing rpms at http://www.cenolan.com/fedora8/ for
2.6.24.3-34?
> 
> I would love to not have to compile from scratch as I have been having trouble
> getting them to boot on my MacBook for whatever weird reason.

Yes, I'll put my patched kernel up ASAP.
Comment 16 Chuck Ebbert 2008-03-19 10:51:19 EDT
Created attachment 298521 [details]
Update to Apple aluminum keyboard key mappings

Looks like they will change the key mappings before 2.6.25 gets released...
Comment 17 Chris Nolan 2008-03-19 11:22:09 EDT
Not sure I entirely agree with those new key mappings but I'll trust they know
what they're doing more than me! At least it looks like 2.6.25 will have full
support for Mac keyboards/touchpads.

Now, as for 2.6.24 - can we get this patch included? PLEASE!! It would be a
great feather in the cap for F8 to have full support for the macbook
out-of-the-box. And I'm sick of compiling kernels ;)
Comment 18 Chuck Ebbert 2008-03-19 14:53:20 EDT
In 2.6.24.3-47
Comment 19 Fedora Update System 2008-03-20 23:15:13 EDT
kernel-2.6.24.3-50.fc8 has been submitted as an update for Fedora 8
Comment 20 Fedora Update System 2008-03-21 18:16:29 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update kernel'.  You can provide feedback for this update here: http://admin.fedoraproject.org/updates/F8/FEDORA-2008-2630
Comment 21 Fedora Update System 2008-03-26 13:14:41 EDT
kernel-2.6.24.3-50.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 22 Chris Nolan 2008-03-27 06:50:03 EDT
kernel-2.6.24.3-50.fc8 works beautifully, thank you!
Comment 23 David Woodhouse 2008-09-10 21:35:41 EDT
The patch which went upstream for this seems to have a different set of quirks for USB_DEVICE_ID_APPLE_WELLSPRING2_ISO -- and the touchpad doesn't work there. I suspect it won't work on the rawhide kernel either, although it works with F-9.

Note You need to log in before you can comment on or make changes to this bug.