Bug 4266 - too many BOOTP or DHCP domain-name-servers cause installer to SEGF
too many BOOTP or DHCP domain-name-servers cause installer to SEGF
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
Depends On:
  Show dependency treegraph
Reported: 1999-07-30 05:39 EDT by chris
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2000-02-11 10:12:53 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description chris 1999-07-30 05:39:58 EDT
The following dhcpd.conf configuration will cause the
redhat-6.0 installer (also under 5.2 and 5.1, none others
tested) to segfault just after the DHCP or BOOTP request.

subnet netmask {
        option routers;
        option domain-name-servers,,,;
#       option domain-name-servers;
        option domain-name "melb.interline.aust.com";
        range dynamic-bootp;

It will work fine if the domain-name-servers is wound back
to a single entry (as per the commented field). Only 4 or 1
entries tested.

Recommended fix is to not segfault (duh!), but just ignore
any execess entries. (ie, if your initial nameservers are
broken, you should be fixing the problem rather than
installing a new redhat box ;)
Comment 1 Jay Turner 1999-08-02 11:26:59 EDT
*** Bug 4274 has been marked as a duplicate of this bug. ***

I have tried to install RH 6.0 on a Pentium II system using
bootnet.img. System has a 3com 3c900 card. I am running a
FreeBSD DHCP ( ISC ) server. When it gets to requesting DHCP
for an IP address I get
"install exited abnormally -- recieved signal 11"
message. On other consoles it indicates that address was
succesfully obtained from DHCP. DHCP serves IP address,
default router, DNS servers, WINS server and NetBIOS node
type 0x8. If you need more information write me.

------- Additional Comments From jeld@mindless.com  07/30/99 12:52 -------
Sorry. It looks that I have encountered the same problem as is
described in bug #4266. I have changed DHCP config and the problem
went away. This is still a bug though :) now I have to change the
dhcp.conf back and restart it just because I tried to install an RH
station :)
Comment 2 Jay Turner 2000-02-11 10:12:59 EST
Fixed in the latest version of the installer.

Note You need to log in before you can comment on or make changes to this bug.