Bug 426685 - firefox hangs in on bugzilla query page
firefox hangs in on bugzilla query page
Status: CLOSED DUPLICATE of bug 431162
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Gecko Maintainer
Fedora Extras Quality Assurance
https://bugzilla.redhat.com/query.cgi...
:
: 431078 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 06:57 EST by John Ellson
Modified: 2008-02-16 13:32 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-16 13:32:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/X11/xorg.conf (4.89 KB, text/plain)
2008-01-02 09:39 EST, John Ellson
no flags Details
/var/log/Xorg.0.log (nvidia) (29.58 KB, text/plain)
2008-01-02 09:41 EST, John Ellson
no flags Details
/var/log/Xorg.20.log (nvidia) (30.08 KB, text/plain)
2008-01-02 09:42 EST, John Ellson
no flags Details
/var/log/Xorg.21.log (29.92 KB, text/plain)
2008-01-02 09:42 EST, John Ellson
no flags Details
/var/log/Xorg.0.log - using automatic configuration (63.35 KB, text/plain)
2008-01-02 10:19 EST, John Ellson
no flags Details

  None (edit)
Description John Ellson 2007-12-24 06:57:59 EST
Description of problem:
firefox hangs in on bugzilla query page
  https://bugzilla.redhat.com/query.cgi?format=simple

Version-Release number of selected component (if applicable):
firefox-3.0-0.beta2.3.fc9.x86_64

How reproducible:
100%

Steps to Reproduce:
1.firefox firefox-3.0-0.beta2.3.fc9.x86_64
2.
3.
  
Actual results:
firefox hangs using 100% of 1 cpu core.

Expected results:
Normal display of page

Additional info:
( Sorry if dup.  Because of this bug I can't check. )
Comment 1 Christopher Aillon 2007-12-24 07:47:47 EST
This happens for me if I'm using the nv driver.  If I switch to the vesa driver,
I don't hang... 
Comment 2 John Ellson 2007-12-24 08:19:12 EST
I'm using GeForce 7600GT with the NVidia 169.07 drivers on
kernel-2.6.23.9-85.fc8 with xorg* from fc8.

I know, I'm a bad boy ;)     I'm relieved you were able to recreate the bug with
the nv drivers.
Comment 3 Christopher Aillon 2007-12-24 14:39:52 EST
Can you try the mesa and nv drivers for reference?  Does nv help?  Does mesa
help?  This could be a driver issue...
Comment 4 John Ellson 2007-12-24 15:17:48 EST
I assume you meant "vesa", not "mesa" ?

I get the same problem with: nvidia, nv, and vesa drivers.

If I wait long enough (~2min) the "component" box on the web page get bigger
with some text in it, but greayed out still.  if I wait longer still (+~2min) I
get the error popup:

    A script on this page may be busy, or it may have stopped responding.
    You can stop the script now, or you can continue to see if the script
    will complete.

    Script: https://bugzilla.redhat.com/js/product_query.js:53

This happens with all three drivers.
Comment 5 Matěj Cepl 2008-01-02 08:19:01 EST
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 6 John Ellson 2008-01-02 09:39:56 EST
Created attachment 290657 [details]
/etc/X11/xorg.conf
Comment 7 John Ellson 2008-01-02 09:41:30 EST
Created attachment 290658 [details]
/var/log/Xorg.0.log (nvidia)
Comment 8 John Ellson 2008-01-02 09:42:08 EST
Created attachment 290659 [details]
/var/log/Xorg.20.log (nvidia)
Comment 9 John Ellson 2008-01-02 09:42:34 EST
Created attachment 290660 [details]
/var/log/Xorg.21.log
Comment 10 John Ellson 2008-01-02 09:44:26 EST
confirming that the problem still occurs with firefox-3.0-0.beta2.4.fc9.x86_64

will do the fresh /etc/X11/xorg.conf next...
Comment 11 John Ellson 2008-01-02 10:19:04 EST
Created attachment 290663 [details]
/var/log/Xorg.0.log - using automatic configuration
Comment 12 John Ellson 2008-01-02 10:20:48 EST
Same browser problem still exists with the automatic configuration  (which only
finds one of the two monitors, but I guess you know that.)
Comment 13 Adam Jackson 2008-01-22 13:10:08 EST
top says that although ff3 is using astonishing amounts of X CPU time normally,
when this hang happens it's all in firefox.
Comment 14 petrosyan 2008-02-06 03:31:51 EST
*** Bug 431078 has been marked as a duplicate of this bug. ***
Comment 15 Adam Jackson 2008-02-11 17:22:11 EST
Minor shenanigans ensue trying to get usable xulrunner-debuginfo.  Still looking
into it...
Comment 16 Matěj Cepl 2008-02-16 13:32:56 EST
Ajax, unless you violently oppose to the idea (and reopen this bug) I am closing
this as duplicate of bug 431162

*** This bug has been marked as a duplicate of 431162 ***

Note You need to log in before you can comment on or make changes to this bug.