Bug 426695 - can not start yum after install yum update today (Component: pirut error)
can not start yum after install yum update today (Component: pirut error)
Status: CLOSED DUPLICATE of bug 426693
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 08:23 EST by jiu ke
Modified: 2007-12-24 10:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-24 10:00:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
can not start yum after install yum update today (1.63 KB, application/octet-stream)
2007-12-24 08:23 EST, jiu ke
no flags Details

  None (edit)
Description jiu ke 2007-12-24 08:23:08 EST
Description of problem:

can not start Add/Remove Program (Pirut), after install updates (including a yum
update) today. Error message:

"Component: pirut
Summary: TBaa979ac4 priorities.py:88:exclude_hook:AttributeError: 'NoneType'
object has no attribute 'samearch'
.......
.......
  File "/usr/lib/yum-plugins/priorities.py", line 88, in exclude_hook
    if opts.samearch:
AttributeError: 'NoneType' object has no attribute 'samearch'

Local variables in innermost frame:
conduit: <yum.plugins.MainPluginConduit instance at 0x9d32b0c>
commands: None
opts: None"

Please see attached for more details.

I also reported a bug related to pirut yesterday: id 426637

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 jiu ke 2007-12-24 08:23:08 EST
Created attachment 290349 [details]
can not start yum after install yum update today
Comment 2 Jeremy Katz 2007-12-24 10:00:51 EST

*** This bug has been marked as a duplicate of 426693 ***

Note You need to log in before you can comment on or make changes to this bug.