Bug 426717 - tar -l option does not functrion.
tar -l option does not functrion.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
8
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Radek Brich
Fedora Extras Quality Assurance
:
: 434648 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-24 17:38 EST by Steve Alexander
Modified: 2008-02-25 03:54 EST (History)
1 user (show)

See Also:
Fixed In Version: 1.17-6.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-17 07:04:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Alexander 2007-12-24 17:38:59 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.1.10) Gecko/20071128 Fedora/2.0.0.10-2.fc8 Firefox/2.0.0.10

Description of problem:
The tar -l and --one-file-system are documented as being identical.  -l does not work as expected, --one-file-system does.


Version-Release number of selected component (if applicable):
tar-1.17-4.fc8

How reproducible:
Always


Steps to Reproduce:
1. mount something in /media
2.tar -c -l -vf /dev/null /media # observe verbose list
3.tar -c --one-file-system -vf /dev/null /media # observe correct and stderr msg


Actual Results:
[root@lycoperdon media]# tar -c -l -vf /dev/null /media
tar: Removing leading `/' from member names
/media/
/media/.hal-mtab
/media/.hal-mtab-lock
/media/_boot1/
/media/_boot1/lost+found/


Expected Results:
[root@lycoperdon media]# tar -c --one-file-system -vf /dev/null /media
tar: Removing leading `/' from member names
/media/
/media/.hal-mtab
/media/.hal-mtab-lock
/media/_boot1/
tar: /media/_boot1/: file is on a different filesystem; not dumped


Additional info:
It appears that -l option is not correctly parsed or handled in the tar command.
Comment 1 Radek Brich 2008-01-03 08:33:18 EST
This is error in documentation -- man page is obsolete.

In tar 1.15.1 source there is following comment for option '-l':
      /* Historically equivalent to --one-file-system. This usage is
         incompatible with UNIX98 and POSIX specs and therefore is
         deprecated. The semantics of -l option will be changed in
         future versions. See TODO.
      */

In tar 1.17 (which is in F8) and later, there really is new semantics for "-l",
it is now equivalent to --check-links.
Comment 2 Fedora Update System 2008-01-22 10:39:30 EST
tar-1.17-6.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update tar'
Comment 3 Radek Brich 2008-02-25 03:54:42 EST
*** Bug 434648 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.