Bug 434648 - -l/--one-file-system documentation misleading
Summary: -l/--one-file-system documentation misleading
Status: CLOSED DUPLICATE of bug 426717
Alias: None
Product: Fedora
Classification: Fedora
Component: tar (Show other bugs)
(Show other bugs)
Version: 8
Hardware: All Linux
low
high
Target Milestone: ---
Assignee: Radek Brich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2008-02-23 22:47 UTC by JW
Modified: 2008-02-25 08:54 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-25 08:54:41 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description JW 2008-02-23 22:47:19 UTC
Description of problem:
The tar man documentation indicates that "-l" and "--one-file-system" are one
and the same.  Unfortunately "-l" and "--check-links" are now one and the same.
 It would be a good idea to update the documentation, given such a dramatic change.

Version-Release number of selected component (if applicable):
tar-1.17-4

How reproducible:
Always

Steps to Reproduce:
1. select a filesystem with a mount point on it (eg /)
2. tar -c -l -f /somewhere/tarfile1
3. tar -c --one-file-system -f /somewhere/tarfile2
  
Actual results:
tarfile1 and tarfile2 are not the same. Step2 probably filled /somewhere to
overflowing.  But man documentation says:
>>     -l, --one-file-system
>>         stay in local file system when creating an archiv

Expected results:
man documentation should be accurate

Additional info:
Info documentation is great, but who has the time to read such voluminous
documentation? Some people prefer concise documentation such as man (if only the
GNU people could come to terms with this alarming concept).

Comment 1 Radek Brich 2008-02-25 08:54:41 UTC
This is already fixed in tar-1.17-7.fc8

*** This bug has been marked as a duplicate of 426717 ***


Note You need to log in before you can comment on or make changes to this bug.