Bug 426755 - RFE: report yum actions like RHN does in RHEL
RFE: report yum actions like RHN does in RHEL
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-cron (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: Habig, Alec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-25 15:59 EST by Milan Kerslager
Modified: 2008-01-22 10:54 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.7-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:34:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for cron.daily (2.55 KB, patch)
2007-12-25 16:02 EST, Milan Kerslager
no flags Details | Diff
Patch for /etc/sysconfig/yum-cron (987 bytes, patch)
2007-12-25 16:02 EST, Milan Kerslager
no flags Details | Diff

  None (edit)
Description Milan Kerslager 2007-12-25 15:59:21 EST
I like RHN's (Red Hat Network) summary sended by email when an action has been done.

Here are two patches to allow yum-cron create similar report and send it by
email. This method uses yum capability of simple logging. I'm using this method
since RHEL3 to support my own repositories.

Please extend yum-cron capability. The default behavior has been preserved
(default cron's method by sending output of a conjob by email).

New option can be enabled by uncomenting MAILTO and OPTIONS lines in
/etc/sysconfig/yum-cron file.
Comment 1 Milan Kerslager 2007-12-25 16:02:08 EST
Created attachment 290383 [details]
Patch for cron.daily
Comment 2 Milan Kerslager 2007-12-25 16:02:54 EST
Created attachment 290384 [details]
Patch for /etc/sysconfig/yum-cron
Comment 3 Habig, Alec 2008-01-08 14:40:21 EST
Looks good, working it in now (sorry for the mostly holiday-induced delay).
Will combine with the errorlevel option suggested in bug 426047 and put
something in testing Real Soon Now.
Comment 4 Habig, Alec 2008-01-10 13:20:24 EST
This (combined with the related request in bug 426047) has been implemented in
yum-cron 0.7-1 in the devel branch, see also
http://koji.fedoraproject.org/koji/buildinfo?buildID=30890

Please try it out.
Comment 5 Fedora Update System 2008-01-11 17:02:00 EST
yum-cron-0.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-cron'
Comment 6 Fedora Update System 2008-01-11 17:22:38 EST
yum-cron-0.7-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-cron'
Comment 7 Fedora Update System 2008-01-22 10:34:01 EST
yum-cron-0.7-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Fedora Update System 2008-01-22 10:54:35 EST
yum-cron-0.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.