Bug 426047 - Have parameter for setting debug level
Have parameter for setting debug level
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: yum-cron (Show other bugs)
8
All Linux
medium Severity low
: ---
: ---
Assigned To: Habig, Alec
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-12-17 19:06 EST by Tim Niemueller
Modified: 2008-01-22 10:54 EST (History)
0 users

See Also:
Fixed In Version: 0.7-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-22 10:34:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/etc/cron.weekly/yum.cron (622 bytes, application/octet-stream)
2007-12-18 10:47 EST, Tim Niemueller
no flags Details
/etc/cron.daily/yum.cron (1.41 KB, application/octet-stream)
2007-12-18 10:47 EST, Tim Niemueller
no flags Details
/etc/sysconfig/yum-cron (455 bytes, application/octet-stream)
2007-12-18 10:48 EST, Tim Niemueller
no flags Details

  None (edit)
Description Tim Niemueller 2007-12-17 19:06:46 EST
Description of problem:
Since I only use yum-cron for quite a few machines to upgrade them I like to get
emails about what has been done during the upgrade. The simple logwatch output
is insufficient as it does not log what was written to the console by updates.

I propose to add a variable DEBUG_LEVEL to /etc/sysconfig/yum-cron that is then
used in the yum cron scripts with the -d parameter (which is currently hardcoded
to 0, which would then be the default in /etc/sysconfig/yum-cron). Currently I
upgrade the scripts but they will be overridden if there is an update to yum-cron.
Comment 1 Habig, Alec 2007-12-18 10:06:51 EST
That's a good idea.  Could you please post your changes as attachments to this
bug, and I'll work to incorporate them?

Be aware that some things in yum itself to not respect the verbosity levels, see
bug 32961 and bug 379011.
Comment 2 Habig, Alec 2007-12-18 10:07:22 EST
Oops, that's bug 329261 and bug 379011.
Comment 3 Habig, Alec 2007-12-18 10:08:23 EST
Dang it, wish I could either type correctly or edit old comments.  Trying again:

 bug 329261 and bug 370911.
Comment 4 Tim Niemueller 2007-12-18 10:43:25 EST
Youp, I have looked at these reports. Since it has worked for me now for a few
years I don't see why this shouldn't work in the future.

I'll post the two files as attachments now with my changes. I have added
ERROR_LEVEL as well.
Comment 5 Tim Niemueller 2007-12-18 10:47:14 EST
Created attachment 289896 [details]
/etc/cron.weekly/yum.cron
Comment 6 Tim Niemueller 2007-12-18 10:47:40 EST
Created attachment 289897 [details]
/etc/cron.daily/yum.cron
Comment 7 Tim Niemueller 2007-12-18 10:48:04 EST
Created attachment 289898 [details]
/etc/sysconfig/yum-cron
Comment 8 Habig, Alec 2008-01-10 13:20:53 EST
This (combined with the related request in bug 426755) has been implemented in
yum-cron 0.7-1 in the devel branch, see also
http://koji.fedoraproject.org/koji/buildinfo?buildID=30890

Please try it out.
Comment 9 Fedora Update System 2008-01-11 17:01:56 EST
yum-cron-0.7-1.fc8 has been pushed to the Fedora 8 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-cron'
Comment 10 Fedora Update System 2008-01-11 17:22:37 EST
yum-cron-0.7-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update yum-cron'
Comment 11 Fedora Update System 2008-01-22 10:33:59 EST
yum-cron-0.7-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 12 Fedora Update System 2008-01-22 10:54:33 EST
yum-cron-0.7-1.fc8 has been pushed to the Fedora 8 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.